Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Re-add data files here.

  • Loading branch information...
commit 02f5bec78dfd415db8bca5215b7526558e42e20a 1 parent b819dfd
Rémy Oudompheng authored
77 data/ghc-provides.txt
View
@@ -0,0 +1,77 @@
+##
+## Core packages and their versions. These come with
+## ghc, so we should be right.
+##
+## http://haskell.org/haskellwiki/Libraries_released_with_GHC
+##
+## And what Arch Linux thinks GHC provides:
+##
+## http://repos.archlinux.org/wsvn/packages/ghc/repos/extra-x86_64/PKGBUILD
+##
+## Note: we could just list these directly, and have yaourt solve them.
+##
+## NEW POLICY:
+## We rely on all "provides" from the GHC library to be listed explicitly.
+##
+
+base==4.1.0.0
+dph-base
+dph-par
+dph-prim-interface
+dph-prim-par
+dph-prim-seq
+dph-seq
+ghc
+ghc-prim
+integer
+integer-gmp
+ghc-binary
+
+## Official Provides: http://repos.archlinux.org/wsvn/packages/ghc/repos/extra-x86_64/PKGBUILD
+#array==0.3.0.1
+#bytestring==0.9.1.7
+#cabal==1.8.0.6
+#containers==0.3.0.0
+#directory==1.0.1.1
+#extensible-exceptions==0.1.1.1
+#filepath==1.1.0.4
+#haskell98==1.0.1.1
+#hpc==0.5.0.5
+#old-locale==1.0.0.2
+#old-time==1.0.0.5
+#pretty==1.0.1.1
+#process==1.0.1.3
+#random==1.0.0.2
+#syb==0.1.0.2
+#template-haskell==2.4.0.1
+#time==1.1.4
+#unix==2.4.0.2
+#haddock==2.6.0
+## utf8-string
+#
+#
+## Removed in 6.12.x
+# html==1.0.1.2
+# integer==0.1.0.0
+# QuickCheck==1.2.0.0
+# haskell-src==1.0.1.3
+# parsec==2.1.0.0
+# packedstring==0.1.0.1
+# parallel==1.1.0.0
+# network==2.2.0.1
+# mtl==1.1.0.2
+# stm==2.1.1.2
+# HUnit==1.2.0.3
+# xhtml==3000.2.0.1
+# regex-base==0.72.0.2
+# regex-compat==0.71.0.1
+# regex-posix==0.72.0.2
+#
+## Removed in 6.10.x
+# editline
+# ALUT==2.1.0.0
+# cgi==3001.1.5.1
+# fgl==5.4.1.1 -- gone
+# GLUT==2.1.1.1
+# OpenAL==1.3.1.1 -- gone
+# readline==1.0.1.0
110 data/library-providers.txt
View
@@ -0,0 +1,110 @@
+# This file lists external library dependencies and the ArchLinux
+# packages providing them. For example, if the openssl package
+# provides libssl.so, there should be a line
+#
+# ssl openssl
+#
+
+Imlib2 imlib2
+SDL sdl
+adns adns
+alut freealut
+bz2 bzip2
+cblas blas
+crack cracklib
+crypto openssl
+curl curl
+freetype freetype2
+glib glib2
+wmflite libwmf
+il devil
+
+jpeg libjpeg
+ldap libldap
+pcap libpcap
+png libpng
+x11 libx11
+xrandr libxrandr
+xml2 libxml2
+libxml libxml2
+exif libexif
+tiff libtiff
+sndfile libsndfile
+gcrypt libgcrypt
+gnutls gnutls
+gnutls-extra gnutls
+fftw3 fftw
+
+pq postgresql
+ssl openssl
+wx wxgtk
+odbc unixodbc
+z zlib
+curses ncurses
+xslt libxslt
+uuid e2fsprogs
+ev libev
+pthread glibc
+m glibc
+gl mesa
+glu mesa
+glut freeglut
+db_cxx db
+sqlite3 sqlite3
+xdamage libxdamage
+
+icui18n icu
+icuuc icu
+icudata icu
+
+netsnmp net-snmp
+asound alsa-lib
+ffi libffi
+ogg libogg
+theora libtheora
+mtp libmtp
+cv opencv
+highgui opencv
+xss libxss
+idn libidn
+libgsasl gsasl
+event libevent
+gcc_s gcc-libs
+stdc++ gcc-libs
+
+# subsumed into glib
+
+gobject glib2
+gmodule glib2
+gio glib2
+gthread glib
+gnome-vfs-module
+gstreamer-audio gstreamer0.10-base
+gstreamer-base gstreamer0.10
+gstreamer-controller gstreamer0.10
+gstreamer-dataprotocol gstreamer0.10
+gstreamer-net gstreamer0.10
+ogremain
+
+webkit libwebkit
+cairo cairo
+pango pango
+pangocairo pango
+gtk+ gtk2
+gdk gtk
+gdk-x11-2.0 gtk2
+gtk-x11-2.0 gtk2
+vte vte
+xine xine-lib
+ncurses ncurses
+ncursesw ncurses
+panel ncurses
+
+gstreamer gstreamer0.10
+gstreamer-plugins-base gstreamer0.10-base
+
+# Packages from AUR
+xenctrl xen
+csound64 csound5
+doublefann fann
+zmq zeromq
44 data/platform-provides.txt
View
@@ -0,0 +1,44 @@
+# Packages in GHC 6.12
+array ==0.3.0.1
+bytestring ==0.9.1.7
+Cabal ==1.8.0.6
+containers ==0.3.0.0
+directory ==1.0.1.1
+extensible-exceptions ==0.1.1.1
+filepath ==1.1.0.4
+haskell98 ==1.0.1.1
+hpc ==0.5.0.5
+old-locale ==1.0.0.2
+old-time ==1.0.0.5
+pretty ==1.0.1.1
+process ==1.0.1.3
+random ==1.0.0.2
+syb ==0.1.0.2
+template-haskell ==2.4.0.1
+time ==1.1.4
+unix ==2.4.0.2
+# Packages in HP 2010.2
+cgi ==3001.1.7.3
+fgl ==5.4.2.3
+GLUT ==2.1.2.1
+haskell-src ==1.0.1.3
+html ==1.0.1.2
+HUnit ==1.2.2.1
+mtl ==1.1.0.2,
+network ==2.2.1.7
+OpenGL ==2.2.3.0
+parallel ==2.2.0.1
+parsec ==2.1.0.1
+QuickCheck ==2.1.1.1
+regex-base ==0.93.2
+regex-compat ==0.93.1
+regex-posix ==0.94.2
+stm ==2.1.2.1
+xhtml ==3000.2.0.1
+zlib ==0.5.2.0
+HTTP ==4000.0.9
+deepseq ==1.1.0.0
+cabal-install ==0.8.2
+alex ==2.3.3
+happy ==1.18.5
+haddock ==2.7.2
Please sign in to comment.
Something went wrong with that request. Please try again.