cabal2arch can't parse dependency spec in 'email-validate' #19

peti opened this Issue Dec 25, 2010 · 2 comments


None yet

3 participants

peti commented Dec 25, 2010

The email-validate package specifies the following dependency: "parsec >= 3.0 || == 2.1.*". As far as I can tell, this would allow building the package with the version of parsec that we have in [extra]. Unfortunately, cabal2arch translates that spec into "parsec>=3.0", which causes pacman to refuse to build that package.


See how I solved this in my personal fork of the archlinux module: the cabal library accepts a list of dependency "hints" that can favour a particular version over another.

I've created a platform-provides.txt file that lists the packages of HP 2010.2 so that these versions are used with highest priority. May I push this ?

magthe commented Jan 10, 2011

Rémy, which patch are you referring to? Please provide a link.

@peti peti closed this Nov 17, 2015
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment