Permalink
Browse files

fixing load path

  • Loading branch information...
1 parent 7480af5 commit 71ea09d7603becb59af3eca2db3d36fb99b07c78 @pboling pboling committed Sep 13, 2009
Showing with 6 additions and 6 deletions.
  1. +1 −0 CHANGELOG
  2. +1 −1 VERSION.yml
  3. +1 −1 install.sh
  4. +1 −3 rails/init.rb
  5. +2 −1 subdomain-fu.gemspec
View
@@ -3,6 +3,7 @@
* Added current_domain method
* Added controller & view usage to readme
* Added more tests
+* Fixing load path
== 2009-08-26
View
@@ -1,4 +1,4 @@
---
:minor: 5
-:patch: 0
+:patch: 1
:major: 0
View
@@ -1,2 +1,2 @@
# I use this to make life easier when installing and testing from source:
-rm -rf subdomain-fu-*.gem && gem build subdomain-fu.gemspec && sudo gem uninstall subdomain-fu && sudo gem install subdomain-fu-0.5.0.gem --no-ri --no-rdoc
+rm -rf subdomain-fu-*.gem && gem build subdomain-fu.gemspec && sudo gem uninstall subdomain-fu && sudo gem install subdomain-fu-0.5.1.gem --no-ri --no-rdoc
View
@@ -1,6 +1,4 @@
-# Add this path to ruby load path
-$:.unshift "#{File.dirname(__FILE__)}/../lib"
-
+#Allow whatever Ruby Package tool is being used ot manage load paths. gem auto adds the gem's lib dir to load path.
require 'subdomain-fu' unless defined?(SubdomainFu)
ActionController::Base.send :include, SubdomainFu::Controller
View
@@ -2,7 +2,7 @@
Gem::Specification.new do |s|
s.name = %q{subdomain-fu}
- s.version = "0.5.0"
+ s.version = "0.5.1"
s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
s.authors = ["Michael Bleigh"]
@@ -21,6 +21,7 @@ Gem::Specification.new do |s|
"lib/subdomain-fu.rb",
"lib/subdomain_fu/routing_extensions.rb",
"lib/subdomain_fu/url_rewriter.rb",
+ "init.rb",
"rails/init.rb",
"spec/spec.opts",
"spec/spec_helper.rb",

0 comments on commit 71ea09d

Please sign in to comment.