Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Newer
Older
100644 52 lines (51 sloc) 1.011 kb
b785c6e @argon Added npm package.json
authored
1 {
2 "name": "apn",
3 "description": "An interface to the Apple Push Notification service for Node.js",
0ac3d66 @argon v1.7.3
authored
4 "version": "1.7.3",
b785c6e @argon Added npm package.json
authored
5 "author": "Andrew Naylor <argon@mkbot.net>",
116218a @argon 1.3.2
authored
6 "contributors": [
7 {
8 "name": "Andrew Naylor",
9 "email": "argon@mkbot.net"
10 }
11 ],
12 "keywords": [
13 "apple",
14 "push",
15 "push notifications",
16 "iOS",
17 "apns",
18 "notifications"
b785c6e @argon Added npm package.json
authored
19 ],
037ae6b @argon Introduced an index.js for friendlier require() statements.
authored
20 "main": "index.js",
519c011 @argon Refactored connection handling.
authored
21 "bugs": {
116218a @argon 1.3.2
authored
22 "email": "argon@mkbot.net",
23 "url": "https://github.com/argon/node-apn/issues"
24 },
b785c6e @argon Added npm package.json
authored
25 "repository": {
26 "type": "git",
519c011 @argon Refactored connection handling.
authored
27 "url": "https://github.com/argon/node-apn.git"
b785c6e @argon Added npm package.json
authored
28 },
519c011 @argon Refactored connection handling.
authored
29 "dependencies": {
71398db @argon Revert "node 0.8's npm doesn't seem to support `^` semver"
authored
30 "node-forge": "^0.6.20",
31 "q": "^1.1.0"
116218a @argon 1.3.2
authored
32 },
894f3df @argon Introduced mocha with some early tests for device component.
authored
33 "devDependencies": {
149d8ee @argon Outdated dependencies
authored
34 "chai": "2.x",
92fac27 @argon `resolve` makes more sense than `read`
authored
35 "chai-as-promised": "*",
36 "mocha": "*",
71398db @argon Revert "node 0.8's npm doesn't seem to support `^` semver"
authored
37 "rewire": "^2.3.0",
38 "sinon": "^1.12.2",
39 "sinon-chai": "^2.6.0"
894f3df @argon Introduced mocha with some early tests for device component.
authored
40 },
41 "scripts": {
0f11781 @argon Switched to expect from should in tests
authored
42 "test": "node_modules/.bin/mocha"
894f3df @argon Introduced mocha with some early tests for device component.
authored
43 },
4d5bc3a @argon JShint configuration
authored
44 "jshintConfig": {
e871d32 @argon "use strict";
authored
45 "node": true
4d5bc3a @argon JShint configuration
authored
46 },
116218a @argon 1.3.2
authored
47 "engines": {
a29d695 @argon utf16 surrogate pairs are first supported in 0.8
authored
48 "node": ">= 0.8.0"
519c011 @argon Refactored connection handling.
authored
49 },
50 "license": "MIT"
e4a3550 @porsager Update package.json
porsager authored
51 }
Something went wrong with that request. Please try again.