Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

1.9.2 release for updated Ghost Driver #11452

Closed
ariya opened this issue Jul 2, 2013 · 25 comments
Closed

1.9.2 release for updated Ghost Driver #11452

ariya opened this issue Jul 2, 2013 · 25 comments

Comments

@ariya
Copy link
Owner

@ariya ariya commented Jul 2, 2013

Spinning off from #10939.

@JamesMGreene
Copy link
Collaborator

@JamesMGreene JamesMGreene commented Jul 2, 2013

Updated Qt?

@ariya
Copy link
Owner Author

@ariya ariya commented Jul 2, 2013

@JamesMGreene
Copy link
Collaborator

@JamesMGreene JamesMGreene commented Jul 2, 2013

Oh, I see. I wasn't expecting another 4.8.x release after 5.0 was launched!

@JamesMGreene
Copy link
Collaborator

@JamesMGreene JamesMGreene commented Jul 2, 2013

FYI: WebKit version appears to be 534.34.

@zenany
Copy link

@zenany zenany commented Jul 5, 2013

when to upgrade the webkit version to the one used by most of the browser today,such as 537.36 , 536.

@JamesMGreene
Copy link
Collaborator

@JamesMGreene JamesMGreene commented Jul 5, 2013

@zenany See Issue #10448.
PhantomJS 2.0 will upgrade to Qt 5.0.2 or higher. The included WebKit upgrade will be to version 537.21 or higher.

@detro
Copy link
Collaborator

@detro detro commented Jul 15, 2013

Working on GhostDriver 1.0.4 as we speak.
There are still few bits to clear unfortunately...

@markstos
Copy link

@markstos markstos commented Jul 15, 2013

Thanks Ivan! I appreciate how much faster PhantomJS/GhostDriver is than using a traditional browser with Selenium.

@vitallium
Copy link
Collaborator

@vitallium vitallium commented Jul 16, 2013

Upgrade Qt to 4.8.5 is almost here too - https://github.com/Vitallium/phantomjs/tree/upgrade-qt-to-4.8.5

@detro
Copy link
Collaborator

@detro detro commented Jul 16, 2013

Nice!

@detro
Copy link
Collaborator

@detro detro commented Jul 24, 2013

GhostDriver 1.0.4 is almost ready.
I have just finished closing the last issue.

I'm going to provide a PR for the new version tomorrow: I'm too tired to do it now and I don't want to f**k it up :)

@markstos
Copy link

@markstos markstos commented Jul 25, 2013

Thanks for your persistence, Ivan. I look forward to the release.

Mark

@detro
Copy link
Collaborator

@detro detro commented Jul 25, 2013

1.0.4 of GhostDriver is now released: https://github.com/detro/ghostdriver/releases
Codename: Arghan Div.
Pull Request: #11508

I'd appreciate if a couple of you would be so kind to do a build and try it out.

@markstos
Copy link

@markstos markstos commented Jul 26, 2013

I'd be happy to test binary 64 bit releases of PhantomJS+GhostDriver for Ubuntu.

detro added a commit that referenced this issue Jul 30, 2013
Issues in this release: https://github.com/detro/ghostdriver/issues?labels=1.0.4&state=closed
See GhostDriver Changelog for more details.

Issue #11452 #11452
@ariya
Copy link
Owner Author

@ariya ariya commented Jul 30, 2013

@markstos You can also try to build 1.9 branch.

@ariya
Copy link
Owner Author

@ariya ariya commented Jul 30, 2013

@vitallium Is your 4.8.5 update considered ready to merge?

@vitallium
Copy link
Collaborator

@vitallium vitallium commented Jul 30, 2013

@ariya Yes, it's ready. I'll create a PR soon.

@ariya
Copy link
Owner Author

@ariya ariya commented Aug 29, 2013

@vitallium Rather than waiting for Qt 4.8.5, I am thinking of releasing this one with updated Ghost Driver so that it's not stalled. We can try to have Qt 4.8.5 for 1.9.3. What do you think?

@vitallium
Copy link
Collaborator

@vitallium vitallium commented Aug 29, 2013

@ariya yes, that would be great. Qt 4.8.5 doesn't contain important fixes. And we already have a part of them in our current version.

@markstos
Copy link

@markstos markstos commented Aug 30, 2013

@ariya, I think that's the best plan. 1.9.2 with an updated Ghost Driver will bring some important bug fixes. There is always a next version to continue to improve further.

@JamesMGreene
Copy link
Collaborator

@JamesMGreene JamesMGreene commented Aug 30, 2013

Yup, let's do this. I know a number of other folks very much want the patches for transparent images as well.

@gimler
Copy link

@gimler gimler commented Sep 6, 2013

+1

ariya added a commit that referenced this issue Sep 6, 2013
ariya added a commit that referenced this issue Sep 7, 2013
@ariya
Copy link
Owner Author

@ariya ariya commented Sep 7, 2013

@ariya ariya closed this Sep 7, 2013
ariya added a commit that referenced this issue Sep 8, 2013
jisqyv pushed a commit to jisqyv/phantomjs that referenced this issue Oct 31, 2013
ariya added a commit that referenced this issue Nov 25, 2013
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
7 participants
You can’t perform that action at this time.