Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Support dropping multiple files #71

Open
tomcb1 opened this issue Mar 1, 2019 · 7 comments

Comments

Projects
None yet
4 participants
@tomcb1
Copy link

commented Mar 1, 2019

Title edited (06-03-19). Old title was "Dragging and droping files into ArmorPaint 0.5 and 0.6dev causes a crash on Linux"

Pretty much what the title said and I am not sure if this is a linux specific bug as I currently do not have a windows install to test on.

Low quality gif here: untitled 2

Info about my system:
OS: Manjaro Linux x86_64
Kernel: 4.14.102-1-MANJARO
CPU: AMD FX-8320
GPU: NVIDIA GeForce GTX 1070
DE: KDE Plasma 5.15.1

EDIT: Intrestingly drag and drop does work without flaw if I run the windows build through WINE

@luboslenco

This comment has been minimized.

Copy link
Member

commented Mar 1, 2019

Hm, just tested on my Manjaro + xfce setup and it seems to work there. Maybe related to KDE? Will investigate, thanks for reporting it!

@tomcb1

This comment has been minimized.

Copy link
Author

commented Mar 3, 2019

I found why I could not drag and drop files. I was trying to move file from a folder called "PBR assets". When I changed the name of this folder to "PBRassets" it worked without flaw meaning linux native ArmorPaint could not handle spaces in file paths while the windows version running on wine could.

For example the when the file path had a space:
Could not open file /home/tomjb/Documents/PBR%20assets/[4K]Metal07/Metal07_col.jpg.
The space would show up as a % sign. Hope this helps!

@SojanJanso

This comment has been minimized.

Copy link

commented Mar 5, 2019

I can confirm the same thing happens on Ubuntu 18.04.2 LTS. (armor paint v 0.6 eb30c2a)
For example when dragging textures in the node editor, it worked fine, unless the file, or one of the folders in it's path contained a space.

@tomcb1 tomcb1 changed the title Dragging and droping files into ArmorPaint 0.5 and 0.6dev causes a crash on Linux Dragging and droping files (with a space in the filepath) into ArmorPaint 0.5 and 0.6dev causes a crash on Linux Mar 6, 2019

@tomcb1 tomcb1 changed the title Dragging and droping files (with a space in the filepath) into ArmorPaint 0.5 and 0.6dev causes a crash on Linux Dragging and dropping files (with a space in the filepath) into ArmorPaint 0.5 and 0.6dev causes a crash on Linux Mar 6, 2019

@luboslenco

This comment has been minimized.

Copy link
Member

commented Mar 8, 2019

This was super helpful, thanks. Pushed a fix and uploaded new dev builds, please let me know if you get to re-test it.

@tomcb1

This comment has been minimized.

Copy link
Author

commented Mar 12, 2019

I've retested this with the new 06dev build from gumroad and drag and drop functionality seems to be working fine with filepaths that include a space. Though I have also found that dragging and dropping multiple files will cause ArmourPaint 06dev to crash.

Here is the console output:

Uniform brushScale not found.
Uniform W not found.
Uniform eye not found.
Could not open file /home/tomjb/Documents/PBR assets/4KMetal07/Metal07_disp.jpg
file:///home/tomjb/Documents/PBR assets/4KMetal07/Metal07_met.jpg.
Could not open file /home/tomjb/Documents/PBR assets/4KMetal07/Metal07_disp.jpg
file:///home/tomjb/Documents/PBR assets/4KMetal07/Metal07_met.jpg.
@SojanJanso

This comment has been minimized.

Copy link

commented Mar 12, 2019

I can confirm files with names containing spaces are also working for me in Ubuntu on the latest itch.io build.

@luboslenco luboslenco changed the title Dragging and dropping files (with a space in the filepath) into ArmorPaint 0.5 and 0.6dev causes a crash on Linux Support dropping multiple files Mar 21, 2019

@Daerst

This comment has been minimized.

Copy link

commented Jul 5, 2019

On Windows 10 / latest 0.6rc (9378b62), dropping multiple textures doesn't crash, but it doesn't work either. None of the textures show up in the textures view.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.