Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Document how to exclude the jOOQ Open Source Edition as a transitive dependency, when needed #659

Closed
lukaseder opened this issue Jun 12, 2019 · 3 comments
Milestone

Comments

@lukaseder
Copy link

@lukaseder lukaseder commented Jun 12, 2019

Currently, it seems that SimpleFlatMapper has a transitive compile time dependency on some version of the jOOQ Open Source Edition, which is nice for new projects, but can get in the way when:

Perhaps it would be useful to either:

@arnaudroger

This comment has been minimized.

Copy link
Owner

@arnaudroger arnaudroger commented Jun 12, 2019

I think provided makes sense

@arnaudroger arnaudroger added this to the 6.8.0 milestone Jun 12, 2019
@lukaseder

This comment has been minimized.

Copy link
Author

@lukaseder lukaseder commented Jun 12, 2019

Indeed, especially since in the case of SimpleFlatMapper, the two dependencies (SFM and jOOQ) are both quite independent of one another and can both live without the other, so it is likely the user will want to depend on both explicitly...

@arnaudroger

This comment has been minimized.

Copy link
Owner

@arnaudroger arnaudroger commented Jun 12, 2019

also you are more likely to already have jooq, spring jdbc or any other
I meant to do that at some point just never got to tidy that up ... still a good sign that it is actually a problem :)

arnaudroger added a commit that referenced this issue Jun 18, 2019
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
2 participants
You can’t perform that action at this time.