Install Laravel Framework with any version you want.
PHP
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Failed to load latest commit information.
src
tests
.gitignore
.travis.yml
CHANGELOG.md
LICENSE
README.md
composer.json
laravel
phpunit.xml

README.md

Laravel Installer

Build Status Latest Stable Version Total Downloads Latest Unstable Version License

This laravel installer is an alternative like a symfony installer, where you could choose a specific version to install.

Remember to remove your old laravel installer for prevent conflicts

composer g remove laravel/installer

Installation

composer g require artesaos/laravel-installer

Usage

This installer works like a default laravel installer. The difference is you can choose your version.

laravel new name version

The option --interactive is available. It will ask for packages to require on your project

Replace name for your project name and version for one of the available versions:

4.2

5.0

5.1 - You can use LTS instead

5.2

5.3 - Default version

master - Install from the current master branch

develop - Install the development version from the next release

You can use the help command for instructions:

laravel help new

Changelog

You can view the latest changes here