New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Apache does not start-up at first boot #1

Open
quaxquax opened this Issue Sep 1, 2017 · 0 comments

Comments

Projects
None yet
1 participant
@quaxquax

quaxquax commented Sep 1, 2017

Some users reported that the Apache start/license page is not loading after the first booting of the Bayesforge AIM.

If you canot load the Bayesforge start page you need to log into the image via ssh e.g. on OSX or Linux you'd issue a command like this:

sh -i .aws/west1.pem ubuntu@ec2-54-152-181-32.compute-1.amazonaws.com

where .aws/west1.pem needs to be replaced with the path to your private ssh key and ec2-54-152-181-32.compute-1.amazonaws.com with your EC2 instances public IP address. I.e.

`sh -i ubuntu@

Amazon describes who to connect with Windows using the freeware Putty at this link.

Once you logged into your EC2 session issue the following commands:

sudo systemctl enable apache2
sudo systemctl start apache2

You can check that the Apache web sever was started with:

sudo systemctl status apache2

You should now be able to display the Bayesforge launch page when pointing your browser to you instance's public IP such as http://ec2-54-152-181-32.compute-1.amazonaws.com and follow the instructions to log into your private Bayesforge Jupyter server.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment