Browse files

Incrementing version, preparing for release.

  • Loading branch information...
1 parent 8dd41bc commit 80d87640b20253422379fb4ab2951e58f02a2ba3 @dblock dblock committed Jan 24, 2013
Showing with 10 additions and 5 deletions.
  1. +4 −2 CHANGELOG.md
  2. +5 −2 garner.gemspec
  3. +1 −1 lib/garner/version.rb
View
6 CHANGELOG.md
@@ -1,10 +1,12 @@
-Next Release
-------------
+0.3
+---
+
* Added `Garner::Cache::ObjectIdentity.cache_multi` that can now take an array of bindings to return an array of objects - [@dblock](https://github.com/dblock).
* When fetching an array of objects via `Garner::Cache::ObjectIdentity.cache_multi`, Garner will use `read_multi` if provided by the cache store - [@dblock](https://github.com/dblock).
0.2.1
-----
+
* Faster invalidation on Mongoid model creation, only invalidate class - [@dblock](https://github.com/dblock).
* Invalidate cache after a Mongoid model has been updated or destroyed, not before - [@dblock](https://github.com/dblock).
View
7 garner.gemspec
@@ -5,11 +5,11 @@
Gem::Specification.new do |s|
s.name = "garner"
- s.version = "0.2.1"
+ s.version = "0.3.0"
s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
s.authors = ["Daniel Doubrovkine", "Frank Macreery"]
- s.date = "2013-01-22"
+ s.date = "2013-01-24"
s.description = "Garner is a set of Rack middleware and cache helpers that implement various strategies."
s.email = "dblock@dblock.org"
s.extra_rdoc_files = [
@@ -55,6 +55,7 @@ Gem::Specification.new do |s|
s.add_development_dependency(%q<rspec>, ["~> 2.10"])
s.add_development_dependency(%q<jeweler>, ["= 1.8.3"])
s.add_development_dependency(%q<mongoid>, ["~> 3.0"])
+ s.add_development_dependency(%q<dalli>, ["~> 2.6"])
s.add_development_dependency(%q<yard>, [">= 0"])
s.add_development_dependency(%q<redcarpet>, [">= 0"])
s.add_development_dependency(%q<github-markup>, [">= 0"])
@@ -69,6 +70,7 @@ Gem::Specification.new do |s|
s.add_dependency(%q<rspec>, ["~> 2.10"])
s.add_dependency(%q<jeweler>, ["= 1.8.3"])
s.add_dependency(%q<mongoid>, ["~> 3.0"])
+ s.add_dependency(%q<dalli>, ["~> 2.6"])
s.add_dependency(%q<yard>, [">= 0"])
s.add_dependency(%q<redcarpet>, [">= 0"])
s.add_dependency(%q<github-markup>, [">= 0"])
@@ -84,6 +86,7 @@ Gem::Specification.new do |s|
s.add_dependency(%q<rspec>, ["~> 2.10"])
s.add_dependency(%q<jeweler>, ["= 1.8.3"])
s.add_dependency(%q<mongoid>, ["~> 3.0"])
+ s.add_dependency(%q<dalli>, ["~> 2.6"])
s.add_dependency(%q<yard>, [">= 0"])
s.add_dependency(%q<redcarpet>, [">= 0"])
s.add_dependency(%q<github-markup>, [">= 0"])
View
2 lib/garner/version.rb
@@ -1,3 +1,3 @@
module Garner
- VERSION = '0.2.1'
+ VERSION = '0.3.0'
end

0 comments on commit 80d8764

Please sign in to comment.