Permalink
Browse files

Bumping dependency to activemodel 3.0.0.beta3

  • Loading branch information...
1 parent b91aea5 commit 66355f6c4ffe90b35aa2fb646de94cdcc5362ee1 @durran durran committed Apr 21, 2010
Showing with 18 additions and 14 deletions.
  1. +2 −2 Gemfile
  2. +2 −2 Rakefile
  3. +2 −2 lib/mongoid.rb
  4. +1 −1 lib/mongoid/config.rb
  5. BIN lib/mongoid/extensions/nil/.assimilation.rb.swp
  6. +11 −7 mongoid.gemspec
View
@@ -2,8 +2,8 @@
# Use `bundle exec rake` in order to run the specs using the bundle
source "http://gemcutter.org"
-gem "activemodel", ">= 3.0.beta2"
-gem "will_paginate", ">= 3.0.pre"
+gem "activemodel", "3.0.0.beta3"
+gem "will_paginate", "3.0.pre"
gem "mongo", "0.20.1"
gem "bson", "0.20.1"
gem "bson_ext", "0.20.1"
View
@@ -12,8 +12,8 @@ begin
gem.homepage = "http://mongoid.org"
gem.authors = ["Durran Jordan"]
- gem.add_dependency("activemodel", ">= 3.0.0.beta2")
- gem.add_dependency("will_paginate", ">= 3.0.pre")
+ gem.add_dependency("activemodel", "3.0.0.beta3")
+ gem.add_dependency("will_paginate", "3.0.pre")
gem.add_dependency("mongo", "0.20.1")
gem.add_dependency("bson", "0.20.1")
View
@@ -21,8 +21,8 @@
# WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
require "rubygems"
-gem "activemodel", ">= 3.0.0.beta2"
-gem "will_paginate", ">= 3.0.pre"
+gem "activemodel", "3.0.0.beta3"
+gem "will_paginate", "3.0.pre"
gem "mongo", "0.20.1"
gem "bson", "0.20.1"
View
@@ -100,7 +100,7 @@ def destructive_fields
klass = Class.new do
include Mongoid::Document
end
- klass.instance_methods(true)
+ klass.instance_methods(true).collect { |method| method.to_s }
}.call
end
Binary file not shown.
View
@@ -9,7 +9,7 @@ Gem::Specification.new do |s|
s.required_rubygems_version = Gem::Requirement.new("> 1.3.1") if s.respond_to? :required_rubygems_version=
s.authors = ["Durran Jordan"]
- s.date = %q{2010-04-12}
+ s.date = %q{2010-04-20}
s.email = %q{durran@gmail.com}
s.extra_rdoc_files = [
"README.rdoc"
@@ -148,6 +148,7 @@ Gem::Specification.new do |s|
"spec/integration/mongoid/named_scope_spec.rb",
"spec/integration/mongoid/persistence/update_spec.rb",
"spec/integration/mongoid/persistence_spec.rb",
+ "spec/models/account.rb",
"spec/models/address.rb",
"spec/models/animal.rb",
"spec/models/callbacks.rb",
@@ -167,6 +168,7 @@ Gem::Specification.new do |s|
"spec/models/phone.rb",
"spec/models/post.rb",
"spec/models/translation.rb",
+ "spec/models/user.rb",
"spec/models/vet_visit.rb",
"spec/models/video.rb",
"spec/spec.opts",
@@ -284,6 +286,7 @@ Gem::Specification.new do |s|
"spec/integration/mongoid/named_scope_spec.rb",
"spec/integration/mongoid/persistence/update_spec.rb",
"spec/integration/mongoid/persistence_spec.rb",
+ "spec/models/account.rb",
"spec/models/address.rb",
"spec/models/animal.rb",
"spec/models/callbacks.rb",
@@ -303,6 +306,7 @@ Gem::Specification.new do |s|
"spec/models/phone.rb",
"spec/models/post.rb",
"spec/models/translation.rb",
+ "spec/models/user.rb",
"spec/models/vet_visit.rb",
"spec/models/video.rb",
"spec/spec_helper.rb",
@@ -407,23 +411,23 @@ Gem::Specification.new do |s|
s.specification_version = 3
if Gem::Version.new(Gem::RubyGemsVersion) >= Gem::Version.new('1.2.0') then
- s.add_runtime_dependency(%q<activemodel>, [">= 3.0.0.beta2"])
- s.add_runtime_dependency(%q<will_paginate>, [">= 3.0.pre"])
+ s.add_runtime_dependency(%q<activemodel>, ["= 3.0.0.beta3"])
+ s.add_runtime_dependency(%q<will_paginate>, ["= 3.0.pre"])
s.add_runtime_dependency(%q<mongo>, ["= 0.20.1"])
s.add_runtime_dependency(%q<bson>, ["= 0.20.1"])
s.add_development_dependency(%q<rspec>, ["= 1.3.0"])
s.add_development_dependency(%q<mocha>, ["= 0.9.8"])
else
- s.add_dependency(%q<activemodel>, [">= 3.0.0.beta2"])
- s.add_dependency(%q<will_paginate>, [">= 3.0.pre"])
+ s.add_dependency(%q<activemodel>, ["= 3.0.0.beta3"])
+ s.add_dependency(%q<will_paginate>, ["= 3.0.pre"])
s.add_dependency(%q<mongo>, ["= 0.20.1"])
s.add_dependency(%q<bson>, ["= 0.20.1"])
s.add_dependency(%q<rspec>, ["= 1.3.0"])
s.add_dependency(%q<mocha>, ["= 0.9.8"])
end
else
- s.add_dependency(%q<activemodel>, [">= 3.0.0.beta2"])
- s.add_dependency(%q<will_paginate>, [">= 3.0.pre"])
+ s.add_dependency(%q<activemodel>, ["= 3.0.0.beta3"])
+ s.add_dependency(%q<will_paginate>, ["= 3.0.pre"])
s.add_dependency(%q<mongo>, ["= 0.20.1"])
s.add_dependency(%q<bson>, ["= 0.20.1"])
s.add_dependency(%q<rspec>, ["= 1.3.0"])

0 comments on commit 66355f6

Please sign in to comment.