Permalink
Browse files

Regenerated gemspec for version 1.0.0

  • Loading branch information...
1 parent 1881f3d commit f18e3ca21ea1581256291b36df53391390b8ef68 @durran durran committed Jan 9, 2010
Showing with 18 additions and 8 deletions.
  1. +18 −8 mongoid.gemspec
View
@@ -5,21 +5,21 @@
Gem::Specification.new do |s|
s.name = %q{mongoid}
- s.version = "0.12.0"
+ s.version = "1.0.0"
s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
s.authors = ["Durran Jordan"]
- s.date = %q{2010-01-08}
+ s.date = %q{2010-01-09}
s.email = %q{durran@gmail.com}
s.extra_rdoc_files = [
- "README.textile"
+ "README.rdoc"
]
s.files = [
".gitignore",
".watchr",
"HISTORY",
"MIT_LICENSE",
- "README.textile",
+ "README.rdoc",
"Rakefile",
"VERSION",
"lib/mongoid.rb",
@@ -33,6 +33,7 @@ Gem::Specification.new do |s|
"lib/mongoid/associations/options.rb",
"lib/mongoid/associations/proxy.rb",
"lib/mongoid/attributes.rb",
+ "lib/mongoid/callbacks.rb",
"lib/mongoid/commands.rb",
"lib/mongoid/commands/create.rb",
"lib/mongoid/commands/delete.rb",
@@ -42,6 +43,7 @@ Gem::Specification.new do |s|
"lib/mongoid/commands/destroy_all.rb",
"lib/mongoid/commands/save.rb",
"lib/mongoid/complex_criterion.rb",
+ "lib/mongoid/components.rb",
"lib/mongoid/config.rb",
"lib/mongoid/criteria.rb",
"lib/mongoid/document.rb",
@@ -66,8 +68,10 @@ Gem::Specification.new do |s|
"lib/mongoid/extensions/string/inflections.rb",
"lib/mongoid/extensions/symbol/inflections.rb",
"lib/mongoid/extensions/time/conversions.rb",
- "lib/mongoid/field.rb",
+ "lib/mongoid/fields.rb",
+ "lib/mongoid/fields/field.rb",
"lib/mongoid/finders.rb",
+ "lib/mongoid/indexes.rb",
"lib/mongoid/memoization.rb",
"lib/mongoid/timestamps.rb",
"lib/mongoid/versioning.rb",
@@ -90,6 +94,7 @@ Gem::Specification.new do |s|
"spec/unit/mongoid/associations/options_spec.rb",
"spec/unit/mongoid/associations_spec.rb",
"spec/unit/mongoid/attributes_spec.rb",
+ "spec/unit/mongoid/callbacks_spec.rb",
"spec/unit/mongoid/commands/create_spec.rb",
"spec/unit/mongoid/commands/delete_all_spec.rb",
"spec/unit/mongoid/commands/delete_spec.rb",
@@ -121,7 +126,9 @@ Gem::Specification.new do |s|
"spec/unit/mongoid/extensions/symbol/inflections_spec.rb",
"spec/unit/mongoid/extensions/time/conversions_spec.rb",
"spec/unit/mongoid/field_spec.rb",
+ "spec/unit/mongoid/fields_spec.rb",
"spec/unit/mongoid/finders_spec.rb",
+ "spec/unit/mongoid/indexes_spec.rb",
"spec/unit/mongoid/memoization_spec.rb",
"spec/unit/mongoid/timestamps_spec.rb",
"spec/unit/mongoid/versioning_spec.rb",
@@ -149,6 +156,7 @@ Gem::Specification.new do |s|
"spec/unit/mongoid/associations/options_spec.rb",
"spec/unit/mongoid/associations_spec.rb",
"spec/unit/mongoid/attributes_spec.rb",
+ "spec/unit/mongoid/callbacks_spec.rb",
"spec/unit/mongoid/commands/create_spec.rb",
"spec/unit/mongoid/commands/delete_all_spec.rb",
"spec/unit/mongoid/commands/delete_spec.rb",
@@ -180,7 +188,9 @@ Gem::Specification.new do |s|
"spec/unit/mongoid/extensions/symbol/inflections_spec.rb",
"spec/unit/mongoid/extensions/time/conversions_spec.rb",
"spec/unit/mongoid/field_spec.rb",
+ "spec/unit/mongoid/fields_spec.rb",
"spec/unit/mongoid/finders_spec.rb",
+ "spec/unit/mongoid/indexes_spec.rb",
"spec/unit/mongoid/memoization_spec.rb",
"spec/unit/mongoid/timestamps_spec.rb",
"spec/unit/mongoid/versioning_spec.rb",
@@ -194,22 +204,22 @@ Gem::Specification.new do |s|
if Gem::Version.new(Gem::RubyGemsVersion) >= Gem::Version.new('1.2.0') then
s.add_runtime_dependency(%q<activesupport>, [">= 2.2.2"])
s.add_runtime_dependency(%q<mongo>, [">= 0.18.2"])
- s.add_runtime_dependency(%q<durran-validatable>, [">= 1.8.4"])
+ s.add_runtime_dependency(%q<durran-validatable>, [">= 2.0.0"])
s.add_runtime_dependency(%q<leshill-will_paginate>, [">= 2.3.11"])
s.add_development_dependency(%q<rspec>, [">= 1.2.9"])
s.add_development_dependency(%q<mocha>, [">= 0.9.8"])
else
s.add_dependency(%q<activesupport>, [">= 2.2.2"])
s.add_dependency(%q<mongo>, [">= 0.18.2"])
- s.add_dependency(%q<durran-validatable>, [">= 1.8.4"])
+ s.add_dependency(%q<durran-validatable>, [">= 2.0.0"])
s.add_dependency(%q<leshill-will_paginate>, [">= 2.3.11"])
s.add_dependency(%q<rspec>, [">= 1.2.9"])
s.add_dependency(%q<mocha>, [">= 0.9.8"])
end
else
s.add_dependency(%q<activesupport>, [">= 2.2.2"])
s.add_dependency(%q<mongo>, [">= 0.18.2"])
- s.add_dependency(%q<durran-validatable>, [">= 1.8.4"])
+ s.add_dependency(%q<durran-validatable>, [">= 2.0.0"])
s.add_dependency(%q<leshill-will_paginate>, [">= 2.3.11"])
s.add_dependency(%q<rspec>, [">= 1.2.9"])
s.add_dependency(%q<mocha>, [">= 0.9.8"])

0 comments on commit f18e3ca

Please sign in to comment.