Permalink
Browse files

Fixed a horrible bug

  • Loading branch information...
1 parent bb4c455 commit 3b5067f99eaedcac9e0b18927c18995105c441ce David Padilla committed Jul 15, 2010
Showing with 8 additions and 4 deletions.
  1. +6 −2 README.markdown
  2. +1 −1 Rakefile
  3. +1 −1 lib/generators/autocomplete_generator.rb
View
@@ -19,15 +19,19 @@ I'd recommend you understand what's happening with those 3 tools before attempti
Include the gem on your Gemfile
- gem 'rails3-jquery-autocomplete', '>= 0.1.0', :require => 'autocomplete'
+ gem 'rails3-jquery-autocomplete', '>= 0.1.1', :require => 'autocomplete'
Install it
bundle install
-And then, run the generator
+Run the generator
rails generate autocomplete
+
+And include autocomplete-rails.js on your layouts
+
+ javascript_include_tag "autocomplete-rails.js"
## Usage
View
@@ -2,7 +2,7 @@ require 'rubygems'
require 'rake'
require 'echoe'
-Echoe.new('rails3-jquery-autocomplete', '0.1.0') do |p|
+Echoe.new('rails3-jquery-autocomplete', '0.1.1') do |p|
p.description = "Use jQuery's autocomplete plugin with Rails 3."
p.url = "http://github.com/crowdint/rails3-jquery-autocomplete"
p.author = "David Padilla"
@@ -3,7 +3,7 @@
class AutocompleteGenerator < Rails::Generators::Base
def install
# Copy the unobtrusive JS file
- copy_file('autocomplete-rails.js', 'public/autocomplete-rails.js')
+ copy_file('autocomplete-rails.js', 'public/javascripts/autocomplete-rails.js')
end
def self.source_root

0 comments on commit 3b5067f

Please sign in to comment.