Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Bug in slideshow fixed #164

Closed
arvgta opened this Issue Feb 3, 2019 · 0 comments

Comments

Projects
None yet
1 participant
@arvgta
Copy link
Owner

arvgta commented Feb 3, 2019

After at least one year of having it shut off, I have decided to re-enable the slideshow(it kicks in after 60 seconds of user-inactivity) on the Ajaxify demo site, albeit in a simplified form:

  • The toggleSlide logic has been removed - the slideshow is now turned-off by user activity alone (that should make the code even smaller than before). I reckon, the old feature providing a "graphic of a pin" to shut it off caused more confusement than anything else...

However, there now is a bug visible, that I was not aware of before - here's how to reproduce it:

  1. Traverse to any sub-page
  2. Wait for 60 seconds for the slideshow to commence
  3. Let the slideshow operate for a few seconds
  4. Press the "back" button(several times) -> the user-experience will be heavily distorted

It's worth mentioning, that everything is fine, when the slideshow kicks-in without the user having visited any sub-page.

The issue is obviously, why is the user-experience distorted? (in every browser I tested)


EDIT: Solved


EDIT: Slideshow now documented

@arvgta arvgta changed the title Bug in slideshow Bug in slideshow fixed Mar 5, 2019

@arvgta arvgta closed this Mar 5, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.