"Repeat Last Export" without previous export gives cryptic error message #1247

Closed
blinry opened this Issue Sep 6, 2016 · 4 comments

Comments

Projects
None yet
2 participants

blinry commented Sep 6, 2016

When using the "Repeat Last Export" function without a previous export having ever happened, it gives the message "Aseprite can't save "" files". Should be something more clear.

Aseprite and System version

  • Aseprite version: 1.1.7-dev
  • System: Arch Linux
Owner

dacap commented Sep 6, 2016

Hi @blinry, it's strange. It should show the Export Sprite Sheet by default when no previous export was made. Do you get that message when you create a new sprite and use Repeat Last Export?

dacap added the bug label Sep 6, 2016

blinry commented Sep 6, 2016

Yep! I tried with a clean profile (by moving the ~/.config/aseprite) – it works like you describe there. In my "dirty" profile, this is the sprite_sheet section of the aesprite.ini:

[sprite_sheet]
type = 1
columns = 2
width = 64
height = 32
texture_filename = **filename**

Any more information you could use?

Owner

dacap commented Sep 6, 2016

I think I've the steps to reproduce this issue:

  1. Create a new sprite with Ctrl+N and Enter
  2. Then Ctrl+Shift+X to execute Repeat Last Export (this will open the export sprite sheet dialog)
  3. Click the Output file checkbox and press Export (the first sprite Sprite-0001-png.ini file is created with texture_filename = **filename**)
  4. Then we create a new sprite Ctrl+N and Enter
  5. We press Ctrl+Shift+X to export and the error appears

Thanks for your help! I'll try to fix this issue.

dacap added this to the v1.1 milestone Sep 6, 2016

dacap closed this in 18f9d24 Sep 7, 2016

dacap self-assigned this Sep 7, 2016

blinry commented Sep 8, 2016

That was fast! Thanks, David!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment