Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Symmetry Tools Interfering with Paint-Bucket Tool #1251

Closed
SolarLune opened this Issue Sep 8, 2016 · 1 comment

Comments

Projects
None yet
2 participants
@SolarLune
Copy link

SolarLune commented Sep 8, 2016

Describe your bug report or feature request here

Basically, when you enable symmetry, sometimes (?) the paint-bucket tool goes "through" the pixels and fills in the background. Sometimes it also fills in non-transparent pixel clusters, as well. Here's a video that shows the issue better.

Aseprite and System version

  • Aseprite: Version 1.1.7, installed from .deb
  • System: Linux, Ubuntu Gnome, 16.04:

Here's the example .ase file, as well. To reproduce the issue, enable vertical symmetry, and then try to fill the dark red pixels toward the outer edges of the "scarf".

@dacap dacap added the bug label Sep 8, 2016

@dacap dacap added this to the v1.1 milestone Sep 8, 2016

@dacap dacap self-assigned this Sep 8, 2016

@dacap dacap added the high priority label Sep 8, 2016

@dacap

This comment has been minimized.

Copy link
Member

dacap commented Sep 12, 2016

I think this is related to a "hidden brush size" used in the flood fill. E.g. If choose the paint bucket tool, and then you press the - key several times, this will reduce the brush size to 1 pixel (you cannot see the brush size when the paint bucket is selected, but it's a hidden parameter), and then it should start working correctly.

I'll fix this ASAP.

@dacap dacap closed this in 722b516 Sep 12, 2016

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.