Apply Zoom setting creates artifacts #1349

Closed
TheSilvus opened this Issue Dec 9, 2016 · 3 comments

Comments

Projects
None yet
3 participants
@TheSilvus

When disabling the Apply Zoom background setting zooming in and out creates weird artifacts:
image
They seem to be fixed after you draw above them, but I'm not sure about that

  • Aseprite: v1.2-dev
  • System (Win/OSX/Linux, version, distribution): Linux Arch
@HolyBlackCat

This comment has been minimized.

Show comment
Hide comment
@HolyBlackCat

HolyBlackCat Dec 13, 2016

There is a related bug: With zooming close enough the background cells eventually start to become larger even if apply zoom is disabled.

There is a related bug: With zooming close enough the background cells eventually start to become larger even if apply zoom is disabled.

@dacap dacap added the critical label Dec 14, 2016

@dacap dacap added this to the v1.1 milestone Dec 14, 2016

@dacap dacap self-assigned this Dec 14, 2016

dacap added a commit that referenced this issue Dec 16, 2016

@dacap

This comment has been minimized.

Show comment
Hide comment
@dacap

dacap Dec 16, 2016

Member

Fixed the problem described by @HolyBlackCat in dfa90d1. Now I'll work on the main bug.

Member

dacap commented Dec 16, 2016

Fixed the problem described by @HolyBlackCat in dfa90d1. Now I'll work on the main bug.

@dacap

This comment has been minimized.

Show comment
Hide comment
@dacap

dacap Dec 28, 2016

Member

It looks like 0a68c46 doesn't fix the rendering issues when "apply zoom" is disabled on 16x16 or other sizes. Still reviewing this issue.

Member

dacap commented Dec 28, 2016

It looks like 0a68c46 doesn't fix the rendering issues when "apply zoom" is disabled on 16x16 or other sizes. Still reviewing this issue.

@dacap dacap modified the milestones: v1.1, v1.2 Dec 28, 2016

@dacap dacap closed this in 19b52a6 Dec 28, 2016

dacap added a commit that referenced this issue Dec 28, 2016

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment