Grid preferences not persisting after program shutdown #1380

Closed
KashouC opened this Issue Jan 5, 2017 · 5 comments

Comments

Projects
None yet
2 participants

KashouC commented Jan 5, 2017

The settings for the grid in "Preferences" do not persist after you turn Aseprite off. It works from file to file and for the active file if you change the settings, and both the new and active document settings work, but like I said, they get reset after a restart.

Using Aseprite v1.2-beta6 on Steam
Windows 10 x64

KashouC commented Jan 5, 2017

Actually now that I posted the bug report it got saved... I'll get back to you. It might just be the settings saved from before, but it's weird that the "new document" settings get reset.

KashouC commented Jan 5, 2017

Yeah, I dunno. It works fine now even after a reboot. All I know is that I've had to re-set the settings in the new tab like 8 times the last 3 days.

Owner

dacap commented Jan 10, 2017

It might be related to using two different instances of Aseprite opened. E.g. you changes settings in one Aseprite instance and close it, then you close other Aseprite instance, this one might overwrite the former instance preferences.

dacap added the bug label Jan 10, 2017

KashouC commented Jan 10, 2017

This isn't something I tend to do as Steam doesn't even launch a new window if you accidentally launch Aseprite again, and this bug keeps reappearing over and over again. I'll try to delete all the file settings in Roaming and see if it stops. Maybe there was something residual from an older version or something.

dacap added this to the v1.2 milestone Jan 30, 2017

Owner

dacap commented Jan 30, 2017 edited

Thanks to the help of legacydev_ we've found this bug. The fix will be released in the final v1.2.

EDIT: sorry, I didn't notice that you @KashouC are legacydev_ 😄

dacap closed this Jan 30, 2017

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment