New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Occasionally Cannot Move Selections #1584

Closed
KasumiArai opened this Issue Oct 3, 2017 · 2 comments

Comments

Projects
None yet
2 participants
@KasumiArai

KasumiArai commented Oct 3, 2017

Sometimes when I make a selection, I cannot move it by clicking and dragging. In old versions, the mouse used to change to a different when you moused over a selection. Now, it never changes.

Sometimes I can move the selection and sometimes I cannot. I can't tell what makes the difference if I can or can't, since the icon doesn't change. I can click and it'll work, and I can click and it can not.

cannotmoveselection
I am holding down no keys when I do this, and as can be seen the Marquee Tool is active.

Here is me moving a selection without the icon changing until after I click:
movingwithouticonchange

My keyboard shortcuts file, which may be related. I disabled shift to add selection because I liked being able to press shift before I clicked to drag. Everything used to work in latest beta, and I have changed nothing that I am aware of.

asepritekeyboardshortcuts.zip

Edit: Ah. I am on "Add to selection mode". In previous versions I used this so I could add/move with left click, and subtract with right click. No keyboard keys needed to add, subtract OR move the selection. Perhaps it is this mode that has changed. I very, very much prefer how it was in 1.2-beta12 if it has changed.

Aseprite v1.2.2 Steam, Windows Vista 32 Bit

@dacap

This comment has been minimized.

Show comment
Hide comment
@dacap

dacap Oct 3, 2017

Member

Hi @KasumiArai, this is related to this bug fixing:
https://community.aseprite.org/t/marquee-tool-add-subtract-to-selection/470/9

I'll revert part of the behavior and add a new option in Edit > Preferences > Selection to switch to the new behavior (at least for the Add selection mode).

Member

dacap commented Oct 3, 2017

Hi @KasumiArai, this is related to this bug fixing:
https://community.aseprite.org/t/marquee-tool-add-subtract-to-selection/470/9

I'll revert part of the behavior and add a new option in Edit > Preferences > Selection to switch to the new behavior (at least for the Add selection mode).

@dacap dacap self-assigned this Oct 3, 2017

@dacap dacap added the enhancement label Oct 3, 2017

@dacap dacap added this to the v1.2 milestone Oct 3, 2017

@dacap

This comment has been minimized.

Show comment
Hide comment
@dacap

dacap Oct 3, 2017

Member

The new option (checked by default):

screen shot 2017-10-03 at 15 00 18

Member

dacap commented Oct 3, 2017

The new option (checked by default):

screen shot 2017-10-03 at 15 00 18

@KasumiArai KasumiArai closed this Oct 3, 2017

dacap added a commit that referenced this issue Oct 6, 2017

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment