New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Wrong palette displayed with multiple tabs #676

Closed
KasumiArai opened this Issue May 17, 2015 · 1 comment

Comments

Projects
None yet
2 participants
@KasumiArai

KasumiArai commented May 17, 2015

Open two animated files with different palettes in the same tab group. Begin playing one. Click the other tab. Begin playing the other. The palette window will flash between the two. Stop playing the animation in the current tab. The palette window now displays the palette for the image not currently being edited.

paletteanimationbug2

This is admittedly a pretty weird one. I noticed the palette window flipping out a while ago, but couldn't figure out the cause.

Edit: Okay, found some interesting related bugs. If you then close the not visible and playing tab, the current sprite will have the closed tab's palette displayed until a new frame is displayed in that tab. If you then edit the palette, the current sprite inherits the closed tab's palette.

New Image, because why not?

inheritpalette

Aseprite 1.1-beta3 on Windows Vista 32bit

@dacap dacap added the bug label May 18, 2015

@dacap dacap self-assigned this May 18, 2015

@dacap dacap added this to the v1.1 milestone May 18, 2015

@dacap

This comment has been minimized.

Show comment
Hide comment
@dacap

dacap May 19, 2015

Member

Fixed

Member

dacap commented May 19, 2015

Fixed

@dacap dacap closed this May 19, 2015

dacap added a commit that referenced this issue May 19, 2015

Don't set the palette if we change the current frame of an inactive E…
…ditor

This happens when we press the play button in one Editor (it changes to
PlayState) and we start using other Editor. We don't want to change
the current palette/ColorBar for that animation playing in the background.

Fix #676
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment