New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Spray tool fails with a spray width of 6 or less #838

Closed
KasumiArai opened this Issue Oct 24, 2015 · 2 comments

Comments

Projects
None yet
3 participants
@KasumiArai

KasumiArai commented Oct 24, 2015

  1. Select the spray tool
  2. Change spray width to 7
  3. Spray. It works as intended.
  4. Change spray width to 6.
  5. Spray. No pixels are changed.
    spraytoolfails

Aseprite v1.1.1-beta8 on Windows Vista 32bit

@Fojar

This comment has been minimized.

Show comment
Hide comment
@Fojar

Fojar Oct 27, 2015

Contributor

This happens for several combinations of small values of spray width and speed, when the calculation for how many pixels to spray rounds down to zero. @dacap, I have a fix for this that handles the number of pixels to spray as a fraction; can I submit a pull request?

Contributor

Fojar commented Oct 27, 2015

This happens for several combinations of small values of spray width and speed, when the calculation for how many pixels to spray rounds down to zero. @dacap, I have a fix for this that handles the number of pixels to spray as a fraction; can I submit a pull request?

@dacap

This comment has been minimized.

Show comment
Hide comment
@dacap

dacap Oct 27, 2015

Member

Hi @Fojar, a PR would be great as I didn't see this issue yet.

Member

dacap commented Oct 27, 2015

Hi @Fojar, a PR would be great as I didn't see this issue yet.

@dacap dacap closed this in 5c451d2 Oct 29, 2015

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment