New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Bug: Spacebar-pan key input is ignored immediately after clicking in the frames/layers bar. #877

Closed
oceanhahn opened this Issue Nov 25, 2015 · 3 comments

Comments

Projects
None yet
2 participants
@oceanhahn

oceanhahn commented Nov 25, 2015

Pressing the spacebar immediately after clicking anywhere in the frames/layers bar does not trigger pan image mode. My guess is that the frames/layers bar has focus and that the image editor doesn't know the input is "for it," but I'm not sure if that's how ASEprite works. ;)

In any case, if I switch layers and then go to pan using spacebar, whatever tool I currently have selected (not pan) is invoked instead, so often I'll switch layers and then go to pan the image, but get a nice, long brush streak over my graphic when I wanted to scroll it instead. After any click or (probably any) non-spacebar hotkey invoke in the editor window, spacebar-pan works as normal.

@oceanhahn oceanhahn changed the title from Bug: Spacebar-pan key input is ignored immediately after clicking in the frame/layer bar. to Bug: Spacebar-pan key input is ignored immediately after clicking in the frames/layers bar. Nov 25, 2015

@dacap dacap added the bug label Dec 9, 2015

@dacap dacap added this to the v1.1 milestone Dec 9, 2015

@oceanhahn

This comment has been minimized.

Show comment
Hide comment
@oceanhahn

oceanhahn Jun 13, 2016

Hey again, just wondering if there was any view of this bug getting sorted out on the horizon. ^^;

oceanhahn commented Jun 13, 2016

Hey again, just wondering if there was any view of this bug getting sorted out on the horizon. ^^;

@dacap dacap added the high priority label Jun 13, 2016

@dacap

This comment has been minimized.

Show comment
Hide comment
@dacap

dacap Jun 13, 2016

Member

Hi @oceanhahn, thanks for bring this back. I've just tested and it's quite annoying, I'll try to fix this for the next v1.1 version.

Member

dacap commented Jun 13, 2016

Hi @oceanhahn, thanks for bring this back. I've just tested and it's quite annoying, I'll try to fix this for the next v1.1 version.

@dacap dacap self-assigned this Jun 13, 2016

@dacap dacap closed this in 893f757 Jun 13, 2016

@oceanhahn

This comment has been minimized.

Show comment
Hide comment
@oceanhahn

oceanhahn Jun 13, 2016

Thanks for taking care of this for me! :D

oceanhahn commented Jun 13, 2016

Thanks for taking care of this for me! :D

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment