Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Can 'Jump to Next Frame' looping in tagged frames? #879

Closed
AliveGameStudio opened this Issue Nov 29, 2015 · 4 comments

Comments

Projects
None yet
3 participants
@AliveGameStudio
Copy link

AliveGameStudio commented Nov 29, 2015

Tag feature is a Lifesaver for me, i use it to manage massive characters. But i have a issue with it.

If i have 'Idle'(Frame 1 to 4) and 'Run'(Frame 5 to 9) two animation, when i finished the last frame of 'Run' (Frame 9) and press the next frame button, editor jump to 'Frame 1'. But I want jump to the first frame of 'Run', it is 'Frame 5' .
image

Please tell me if have any way to do this.

And i have another request, when i export file using command, can 'Run' animation first frame start at zero ? Sorry for the trouble
image

@dacap dacap added this to the v1.1 milestone Nov 30, 2015

@dacap

This comment has been minimized.

Copy link
Member

dacap commented Nov 30, 2015

Dup #556

@lazcht

This comment has been minimized.

Copy link

lazcht commented Dec 14, 2018

this seems to be bugging the new version again? or is it just me?

(the tag button in the preview box doesn't seem to work as well?)
2018-12-14_16-35-33

also i'm totally new to github so sorry if i should post a new one instead, let me know. my version is Aseprite v1.2.10-beta4-x64

@dacap

This comment has been minimized.

Copy link
Member

dacap commented Dec 14, 2018

@lazcht sorry but I'm not sure if I understood the GIF 😅 Are you using , and . keys to move through frames? or the arrow keys? See that there is a difference between arrow keys (that do not loop the tag) and , and . keys that they do loop inside the tag:

image

@lazcht

This comment has been minimized.

Copy link

lazcht commented Dec 14, 2018

sorry of the lack of clarity, my problem was the same with the thread starter's. which is, I can't navigate and loop frames inside a tag, instead of looping back on the first frame within tag, it's always back to the first frame. but now i have found my source of problem:

I did change the keyboard shortcut of the next & previous frame with . and , in Menus section, here:
image
and I just noticed Aseprite have similar field (is it the same, though? except the ones in Menus don't have the tag option) regarding the frame navigation on the Commands section, so since I "accidentally" replaced the Go to Previous/Next frame with the same tag function with the Jump to Previous/Next frame, figures why it was not working.

thanks for the quick response @dacap ! sorry for the trouble :')

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.
You signed in with another tab or window. Reload to refresh your session. You signed out in another tab or window. Reload to refresh your session.