Browse files

Release a version that works with more recent Parse::Method::Signatures

  • Loading branch information...
1 parent 351b366 commit 505579d3dd44e917499615547a95a1017bbcf4ed @ashb committed Mar 16, 2009
Showing with 7 additions and 4 deletions.
  1. +3 −2 Changes
  2. +1 −0 MANIFEST.SKIP
  3. +2 −1 Makefile.PL
  4. +1 −1 lib/TryCatch.pm
View
5 Changes
@@ -1,9 +1,10 @@
Version history for TryCatch perl module:
+1.000002 - 2009/04/16 - 21:57
- Update to more modern Parse::Method::Signatures
-1.000001 - Sat 14th Feb 2009 22:16
+1.000001 - 2009/02/14 - 22:16
- Attempt to improve installability with old CPAN toolchains
-1.000000 - Sat 7th Feb 2009 18:00
+1.000000 - 2009/02/07 18:00
- Initial release
View
1 MANIFEST.SKIP
@@ -29,3 +29,4 @@
TryCatch.c
TryCatch.o
TryCatch.bs
+inc/Module/Install/JSONMETA.pm
View
3 Makefile.PL
@@ -17,6 +17,7 @@ my $ok = 1;
# Does the toolchain support configure_requires
# If yes, it should be here already.
can_use('ExtUtils::Depends') or do {
+ warn "***\n* Your CPAN toolchain is out of date. Please upgrade it\n***\n"; sleep 5;
requires 'ExtUtils::Depends';
unshift @INC, "$Bin/inc/EUDeps";
@@ -40,7 +41,7 @@ requires 'Sub::Exporter' => 0.979;
resources repository => 'http://github.com/ashb/trycatch/tree/master';
-jsonmeta;
+jsonmeta();
unless ($ok) {
WriteAll;
View
2 lib/TryCatch.pm
@@ -17,7 +17,7 @@ use Carp qw/croak/;
use base 'DynaLoader';
-our $VERSION = '1.000001';
+our $VERSION = '1.000002';
our $PARSE_CATCH_NEXT = 0;
our ($CHECK_OP_HOOK, $CHECK_OP_DEPTH) = (undef, 0);

0 comments on commit 505579d

Please sign in to comment.