Skip to content
This repository

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse code

Updated dependency information for dateutil-2.1 support.

This has become quite messy, to the point that I had a little look for
a hackable replacement.
  • Loading branch information...
commit 55d92f3268163c3bef902bdb06be706993dd33b5 1 parent 63d0a7c
James Rowe authored May 23, 2012
5  doc/install.rst
Source Rendered
@@ -33,5 +33,6 @@ handling [#]_.  :pypi:`simplejson` is also required when using :mod:`github2`
33 33
 with Python 2.4 or 2.5.  If you install via :pypi:`pip` or :pypi:`easy_install
34 34
 <setuptools>` the dependencies should be installed automatically for you.
35 35
 
36  
-.. [#] You must use :pypi:`python-dateutil` 1.x when working with Python 2.x,
37  
-       the latest 2.x releases are for Python 3.x installations only.
  36
+.. [#] You must use :pypi:`python-dateutil` 1.x when working with Python 2.5 or
  37
+       earlier, the latest 2.x releases are for Python 2.6 and newer
  38
+       installations only.
5  extra/requirements-py25.txt
... ...
@@ -1,2 +1,3 @@
1  
--r requirements.txt
2  
-simplejson>=2.0.9
  1
+httplib2 >= 0.7.0
  2
+python-dateutil < 2.0, >= 2.1
  3
+simplejson >= 2.0.9
2  extra/requirements-py3.txt
... ...
@@ -1,2 +0,0 @@
1  
-httplib2>=0.7.0
2  
-python-dateutil>=2.0
4  extra/requirements.txt
... ...
@@ -1,2 +1,2 @@
1  
-httplib2>=0.7.0
2  
-python-dateutil<2.0
  1
+httplib2 >= 0.7.0
  2
+python-dateutil < 2.0
10  setup.py
@@ -23,10 +23,14 @@
23 23
 if sys.version_info[:2] < (2, 6):
24 24
     install_requires.append('simplejson >= 2.0.9')
25 25
 
26  
-if sys.version_info >= (3,):
27  
-    install_requires.append('python-dateutil >= 2.0')
28  
-else:
  26
+# dateutil supports python 2.x in dateutil-1, python 3.x in dateutil-2.0 and
  27
+# python 2.6+ in dateutil-2.1.  Exciting…
  28
+if sys.version_info[:2] <= (2, 5):
29 29
     install_requires.append('python-dateutil < 2.0')
  30
+elif sys.version_info < (3, ):
  31
+    install_requires.append('python-dateutil < 2.0, >= 2.1')
  32
+else:
  33
+    install_requires.append('python-dateutil > 2.0')
30 34
 
31 35
 long_description = (codecs.open('README.rst', "r", "utf-8").read()
32 36
     + "\n" + codecs.open('NEWS.rst', "r", "utf-8").read())

0 notes on commit 55d92f3

Please sign in to comment.
Something went wrong with that request. Please try again.