Permalink
Browse files

Fixed simplejson dependency for Python 2.4.

Recent versions of simplejson no longer support Python 2.4.
  • Loading branch information...
1 parent 55d92f3 commit a77c23a85a1f2eacebd0697608bbe510e3ee775c @JNRowe JNRowe committed May 23, 2012
Showing with 6 additions and 2 deletions.
  1. +6 −2 setup.py
View
@@ -19,8 +19,12 @@
install_requires = ['httplib2 >= 0.7.0', ]
-# simplejson is included in the standard library since Python 2.6 as json.
-if sys.version_info[:2] < (2, 6):
+
+# simplejson is included in the standard library since Python 2.6 as json
+if sys.version_info < (2, 5):
+ # 2.1 drops support for 2.4
+ install_requires.append('simplejson >= 2.0.9, < 2.1')
+elif sys.version_info[:2] < (2, 6):
install_requires.append('simplejson >= 2.0.9')
# dateutil supports python 2.x in dateutil-1, python 3.x in dateutil-2.0 and

0 comments on commit a77c23a

Please sign in to comment.