Permalink
Browse files

Initial gem skeleton

  • Loading branch information...
aslamnd committed Jul 15, 2011
0 parents commit 77270656e4efa2e1ec5d0c243637c79692964236
@@ -0,0 +1,4 @@
+*.gem
+.bundle
+Gemfile.lock
+pkg/*
@@ -0,0 +1,4 @@
+source "http://rubygems.org"
+
+# Specify your gem's dependencies in lessframework-rails.gemspec
+gemspec
No changes.
@@ -0,0 +1,2 @@
+require 'bundler'
+Bundler::GemHelper.install_tasks
@@ -0,0 +1,26 @@
+# -*- encoding: utf-8 -*-
+$:.push File.expand_path("../lib", __FILE__)
+require "lessframework-rails/version"
+
+Gem::Specification.new do |s|
+ s.name = "lessframework-rails"
+ s.version = Lessframework::Rails::VERSION
+ s.platform = Gem::Platform::RUBY
+ s.authors = ["Aslam Najeebdeen"]
+ s.email = ["aslam@frontcube.com"]
+ s.homepage = "http://github.com/aslamnd/lessframework-rails"
+ s.summary = "Less Frameworks for Rails 3 projects"
+ s.description = "Less Frameworks is an adaptive CSS grid system, helps to make responsive website. This gem provides Less Framwork for your Rails 3 projects. Learn more about Less framwork at http://lessframework.com/"
+
+ s.rubyforge_project = "lessframework-rails"
+
+ s.files = `git ls-files`.split("\n")
+ s.test_files = `git ls-files -- {test,spec,features}/*`.split("\n")
+ s.executables = `git ls-files -- bin/*`.split("\n").map{ |f| File.basename(f) }
+ s.require_paths = ["lib"]
+
+ s.add_dependency "railties", "~> 3.0"
+ s.add_dependency "thor", "~> 0.14"
+ s.add_development_dependency "bundler", "~> 1.0.0"
+ s.add_development_dependency "rails", "~> 3.0"
+end
@@ -0,0 +1,5 @@
+module Lessframework
+ module Rails
+ # Your code goes here...
+ end
+end
No changes.
No changes.
@@ -0,0 +1,5 @@
+module Lessframework
+ module Rails
+ VERSION = "0.0.1"
+ end
+end

0 comments on commit 7727065

Please sign in to comment.