Permalink
Browse files

gemfile was too strict

  • Loading branch information...
Paul Asmuth
Paul Asmuth committed Dec 10, 2011
1 parent fcdd6a5 commit 84b6d6cdcaf49218068259cdb4bdb1755147cc2e
Showing with 27 additions and 31 deletions.
  1. +5 −5 Gemfile
  2. +5 −5 Gemfile.lock
  3. +1 −1 VERSION
  4. +16 −20 fnordmetric.gemspec
View
10 Gemfile
@@ -1,10 +1,10 @@
source "http://rubygems.org"
-gem "mongoid", "~> 2.2.0"
-gem "mongo", "~> 1.4.0"
-gem "bson_ext", "~> 1.4.0"
-gem "sinatra", "~> 1.2.6"
-gem "redis", "~> 2.2.2"
+gem "mongoid", ">= 2.2.0"
+gem "mongo", ">= 1.4.0"
+gem "bson_ext", ">= 1.4.0"
+gem "sinatra", ">= 1.2.6"
+gem "redis", ">= 2.2.2"
gem "eventmachine"
gem "em-hiredis"
gem "json"
View
@@ -70,21 +70,21 @@ PLATFORMS
ruby
DEPENDENCIES
- bson_ext (~> 1.4.0)
+ bson_ext (>= 1.4.0)
bundler (~> 1.0.0)
delorean
em-hiredis
eventmachine
haml
jeweler (~> 1.5.2)
json
- mongo (~> 1.4.0)
- mongoid (~> 2.2.0)
+ mongo (>= 1.4.0)
+ mongoid (>= 2.2.0)
rack
rack-test
- redis (~> 2.2.2)
+ redis (>= 2.2.2)
rspec (~> 2.6.0)
shoulda
- sinatra (~> 1.2.6)
+ sinatra (>= 1.2.6)
thin
yajl-ruby!
View
@@ -1 +1 @@
-0.5.0
+0.5.1
View
@@ -5,7 +5,7 @@
Gem::Specification.new do |s|
s.name = %q{fnordmetric}
- s.version = "0.5.0"
+ s.version = "0.5.1"
s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
s.authors = ["Paul Asmuth"]
@@ -16,7 +16,6 @@ Gem::Specification.new do |s|
".document",
"Gemfile",
"Gemfile.lock",
- "Procfile",
"Rakefile",
"VERSION",
"_spec/app_spec.rb",
@@ -32,7 +31,6 @@ Gem::Specification.new do |s|
"_spec/widget_spec.rb",
"doc/example_server.rb",
"doc/import_dump.rb",
- "em_runner.rb",
"fnordmetric.gemspec",
"haml/app.haml",
"haml/widget.haml",
@@ -84,7 +82,6 @@ Gem::Specification.new do |s|
"pub/raphael-utils.js",
"pub/sprite.png",
"readme.rdoc",
- "server.rb",
"spec/app_spec.rb",
"spec/context_spec.rb",
"spec/dashboard_spec.rb",
@@ -96,7 +93,6 @@ Gem::Specification.new do |s|
"spec/spec_helper.rb",
"spec/widget_spec.rb",
"spec/worker_spec.rb",
- "test_stream.sh",
"ulm_stats.rb"
]
s.homepage = %q{http://github.com/paulasmuth/fnordmetric}
@@ -122,11 +118,11 @@ Gem::Specification.new do |s|
s.specification_version = 3
if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
- s.add_runtime_dependency(%q<mongoid>, ["~> 2.2.0"])
- s.add_runtime_dependency(%q<mongo>, ["~> 1.4.0"])
- s.add_runtime_dependency(%q<bson_ext>, ["~> 1.4.0"])
- s.add_runtime_dependency(%q<sinatra>, ["~> 1.2.6"])
- s.add_runtime_dependency(%q<redis>, ["~> 2.2.2"])
+ s.add_runtime_dependency(%q<mongoid>, [">= 2.2.0"])
+ s.add_runtime_dependency(%q<mongo>, [">= 1.4.0"])
+ s.add_runtime_dependency(%q<bson_ext>, [">= 1.4.0"])
+ s.add_runtime_dependency(%q<sinatra>, [">= 1.2.6"])
+ s.add_runtime_dependency(%q<redis>, [">= 2.2.2"])
s.add_runtime_dependency(%q<eventmachine>, [">= 0"])
s.add_runtime_dependency(%q<em-hiredis>, [">= 0"])
s.add_runtime_dependency(%q<json>, [">= 0"])
@@ -141,11 +137,11 @@ Gem::Specification.new do |s|
s.add_development_dependency(%q<bundler>, ["~> 1.0.0"])
s.add_development_dependency(%q<jeweler>, ["~> 1.5.2"])
else
- s.add_dependency(%q<mongoid>, ["~> 2.2.0"])
- s.add_dependency(%q<mongo>, ["~> 1.4.0"])
- s.add_dependency(%q<bson_ext>, ["~> 1.4.0"])
- s.add_dependency(%q<sinatra>, ["~> 1.2.6"])
- s.add_dependency(%q<redis>, ["~> 2.2.2"])
+ s.add_dependency(%q<mongoid>, [">= 2.2.0"])
+ s.add_dependency(%q<mongo>, [">= 1.4.0"])
+ s.add_dependency(%q<bson_ext>, [">= 1.4.0"])
+ s.add_dependency(%q<sinatra>, [">= 1.2.6"])
+ s.add_dependency(%q<redis>, [">= 2.2.2"])
s.add_dependency(%q<eventmachine>, [">= 0"])
s.add_dependency(%q<em-hiredis>, [">= 0"])
s.add_dependency(%q<json>, [">= 0"])
@@ -161,11 +157,11 @@ Gem::Specification.new do |s|
s.add_dependency(%q<jeweler>, ["~> 1.5.2"])
end
else
- s.add_dependency(%q<mongoid>, ["~> 2.2.0"])
- s.add_dependency(%q<mongo>, ["~> 1.4.0"])
- s.add_dependency(%q<bson_ext>, ["~> 1.4.0"])
- s.add_dependency(%q<sinatra>, ["~> 1.2.6"])
- s.add_dependency(%q<redis>, ["~> 2.2.2"])
+ s.add_dependency(%q<mongoid>, [">= 2.2.0"])
+ s.add_dependency(%q<mongo>, [">= 1.4.0"])
+ s.add_dependency(%q<bson_ext>, [">= 1.4.0"])
+ s.add_dependency(%q<sinatra>, [">= 1.2.6"])
+ s.add_dependency(%q<redis>, [">= 2.2.2"])
s.add_dependency(%q<eventmachine>, [">= 0"])
s.add_dependency(%q<em-hiredis>, [">= 0"])
s.add_dependency(%q<json>, [">= 0"])

0 comments on commit 84b6d6c

Please sign in to comment.