EF Core 2.0 to target .NET Standard 2.0 #246

Open
divega opened this Issue May 25, 2017 · 0 comments

Comments

Projects
None yet
3 participants
@divega
Member

divega commented May 25, 2017

We have the intention to make EF Core 2.0 target .NET Standard 2.0 only. This means you will be able to use Entity Framework Core 2.0 on:

  • .NET Framework 4.6.1 and up
  • .NET Core 2.x
  • Mono 5.x

There will be a period of time during which other .NET platforms will need to catch up to .NET Standard 2.0, e.g. an UWP version with support for .NET Standard 2.0 will arrive later this year, as announced at Build.

EF Core 1.x versions target .NET Framework 4.5.1 and .NET Standard 1.3 and can still be used in older platforms. The documentation on .NET Standard contains a full matrix of .NET platform support.

The change is happening in two stages:

Why do we want to do this?

Because

  • it simplifies our compatibility story for the long term,
  • improves the maintainability of the EF Core codebase,
  • reduces the size of the EF Core packages and all its dependencies significantly (with this change, the Microsoft.Extenions.* packages can also support .NET Standard 2.0 only),
  • and prevents EF Core 2.0 from falsely appearing to be compatible with platforms on which we are not doing any testing.

Please post any questions, feedback or concerns on the following discussion thread: aspnet/EntityFrameworkCore#8598

@aspnet aspnet locked and limited conversation to collaborators May 25, 2017

@danroth27 danroth27 modified the milestone: 2.0.0-preview2 Jun 2, 2017

@danroth27 danroth27 added the 2.0.0 label Aug 3, 2017

@danroth27 danroth27 added 2.0.0 and removed 2.0.0 labels Aug 3, 2017

Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.