Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

<NavLink class="nav-link"> without href="" #1788

Closed
UrielMhezzek opened this Issue Feb 17, 2019 · 1 comment

Comments

Projects
None yet
2 participants
@UrielMhezzek
Copy link

UrielMhezzek commented Feb 17, 2019

If you use NavLink -Component without href in Selfmade-BlazorComponent, the Selfmade-BlazorComponent is no longer loaded and you only get the following message in the console from Browser

Uncaught Error: No element is currently associated with component 7
at e.updateComponent (blazor.server.js:23)
at Object.t.renderBatch (blazor.server.js:16)
at e. (blazor.server.js:38)
at blazor.server.js:16
at Array.forEach ()
at e.invokeClientMethod (blazor.server.js:16)
at e.processIncomingData (blazor.server.js:16)
at e.connection.onreceive (blazor.server.js:16)
at WebSocket.i.onmessage (blazor.server.js:16)

@danroth27

This comment has been minimized.

Copy link
Member

danroth27 commented Feb 18, 2019

This issue was moved to aspnet/AspNetCore#7694

@aspnet aspnet locked and limited conversation to collaborators Feb 18, 2019

@danroth27 danroth27 closed this Feb 18, 2019

Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.
You can’t perform that action at this time.