Skip to content
This repository has been archived by the owner. It is now read-only.

Calling https but getting http schema #551

Closed
imperugo opened this issue Jan 3, 2016 · 6 comments
Closed

Calling https but getting http schema #551

imperugo opened this issue Jan 3, 2016 · 6 comments
Labels

Comments

@imperugo
Copy link

@imperugo imperugo commented Jan 3, 2016

Hi,
I've a strange issue running Kestrel with HTTPS.
It seems the schema is always http also if I call the endpoint using https.

image

Any hint?

For reference: IdentityServer/IdentityServer3#2357

@khellang
Copy link
Contributor

@khellang khellang commented Jan 3, 2016

Are you hitting Kestrel directly or are you running behind a reverse proxy?? Maybe using IISPlatformHandler?

@imperugo
Copy link
Author

@imperugo imperugo commented Jan 3, 2016

Running directly from VS2015 Update1.

app.UseIISPlatformHandler(); is comment out

@khellang
Copy link
Contributor

@khellang khellang commented Jan 3, 2016

Running directly from VS2015 Update1.

Does that mean using IIS Express? Can you dump the headers you're receiving?

@imperugo
Copy link
Author

@imperugo imperugo commented Jan 3, 2016

Nope, running web command from play button in VS.
Same problem using command line (dnx web)

@Tratcher
Copy link
Member

@Tratcher Tratcher commented Jan 3, 2016

Fixed in RC2: #365

@Tratcher Tratcher closed this Jan 3, 2016
@Tratcher Tratcher added the duplicate label Jan 3, 2016
@imperugo
Copy link
Author

@imperugo imperugo commented Jan 3, 2016

Thx,
I'll use this workaround in the meanwhile

Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
3 participants
You can’t perform that action at this time.