Skip to content
This repository has been archived by the owner. It is now read-only.

Microsoft.ApplicationInsights.AspNetCore.dll is missing #286

Closed
ZOXEXIVO opened this issue Aug 21, 2017 · 10 comments

Comments

@ZOXEXIVO
Copy link

commented Aug 21, 2017

Ubuntu 16.04
Used many runtimes, but result is same:

Error:
An assembly specified in the application dependencies manifest (*****.Web.deps.json) was not found:
package: 'Microsoft.ApplicationInsights.AspNetCore', version: '2.1.1'
path: 'lib/netstandard1.6/Microsoft.ApplicationInsights.AspNetCore.dll'
This assembly was expected to be in the local runtime store as the application was published using the following target manifest files:
aspnetcore-store-2.0.0-linux-x64.xml;aspnetcore-store-2.0.0-osx-x64.xml;aspnetcore-store-2.0.0-win7-x64.xml;aspnetcore-store-2.0.0-win7-x86.xml

@natemcmaster

This comment has been minimized.

Copy link
Contributor

commented Aug 22, 2017

Ubuntu 16.04

We don't currently support Ubuntu 16 docker images. Can you explain in more detail what you've done to encounter this error? See https://github.com/aspnet/aspnet-docker/blob/master/.github/ISSUE_TEMPLATE

@heuristicAL

This comment has been minimized.

Copy link

commented Sep 1, 2017

I get the same error when trying to run my app from the microsoft/dotnet:2-runtime docker image. The only way to make it work is to use the microsoft/dotnet:2-sdk docker image but this isn't the best solution for a production environment...

@heuristicAL

This comment has been minimized.

Copy link

commented Sep 1, 2017

As mentioned by the answer on this thread I fixed this error by incorporating the following run command in my Dockerfile. Should work for anyone using the Runtime instead of the SDK:
RUN curl https://dist.asp.net/runtimestore/2.0.0/linux-x64/aspnetcore.runtimestore.tar.gz | tar xz -C /usr/share/dotnet

@natemcmaster

This comment has been minimized.

Copy link
Contributor

commented Sep 1, 2017

@heuristicAL You can save yourself the trouble by using microsoft/aspnetcore:2.0.0.

FROM microsoft/dotnet:2.0.0-runtime-stretch
# set up network
ENV ASPNETCORE_URLS http://+:80
ENV ASPNETCORE_RUNTIMESTORE_DOWNLOAD_URL https://dist.asp.net/runtimestore/2.0.0/linux-x64/aspnetcore.runtimestore.tar.gz
ENV ASPNETCORE_PKG_VERSION 2.0.0
# set up the runtime store
RUN curl -o /tmp/runtimestore.tar.gz $ASPNETCORE_RUNTIMESTORE_DOWNLOAD_URL \
&& export DOTNET_HOME=$(dirname $(readlink $(which dotnet))) \
&& tar -x -C $DOTNET_HOME -f /tmp/runtimestore.tar.gz \
&& rm /tmp/runtimestore.tar.gz

@ZOXEXIVO I'm closing for now as I don't have enough information to resolve your issue. If you are getting this error trying to use microsoft/dotnet:2-runtime, then this is a duplicate of dotnet/dotnet-docker#279

@TAGC

This comment has been minimized.

Copy link

commented Oct 26, 2017

What's the workaround for trying to run an ASP.NET Core 2.0 application on a Raspberry Pi running Ubuntu 16.04? I'm not sure if the runtime store will work if it's targeting linux-x64.

@ZOXEXIVO

This comment has been minimized.

Copy link
Author

commented Oct 26, 2017

Workaround: Don't use AspNetCore.All.dll and include only used packages

@natemcmaster

This comment has been minimized.

Copy link
Contributor

commented Oct 26, 2017

I thought Raspberry Pi was linux-arm32, not linux-x64. ASP.NET Core doesn't support linux-arm32 yet. aspnet/Universe#554

@TAGC

This comment has been minimized.

Copy link

commented Oct 30, 2017

Worked fine after I made it a self-contained app by adding -r linux-arm:

dotnet publish -c Release -r linux-arm -p:SolutionDir=../.. -o /app/dist

@jdelrue

This comment has been minimized.

Copy link

commented Dec 14, 2017

Workaround also works for Ubuntu. Seems like you have to specify your target runtime environment:

dotnet publish -c release -o publish -r linux-x64

This is not the case when using the SDK

@icavalheiro

This comment has been minimized.

Copy link

commented Jul 5, 2018

"-r linux-x64" Fixed it for me.

Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.
Projects
None yet
6 participants
You can’t perform that action at this time.