New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

OVM20 ANET edition para Geonosis #95

Open
JorFru opened this Issue Oct 3, 2018 · 17 comments

Comments

@JorFru
Copy link
Member

JorFru commented Oct 3, 2018

Staticboards nos ha regalado su última creación para que la probemos como betatesters. Conviene instalarla lo antes posible para ir reportando a Javier Loureiro (Staticboards) las sugerencias y bugs de la nueva placa.

La placa original de la Tronxy irá al armario. El MOSFET que actualmente lleva Geonosis se moverá a Spicy #96

@dmarcosm

This comment has been minimized.

Copy link
Contributor

dmarcosm commented Oct 3, 2018

Observaciones de otros betatesters:

  • Los conectores de alimentación de la cama y el extrusor tienen los nombres en la placa intercambiados. Hay que conectar los cables del extrusor a donde pone hotbed y los de la cama donde ponga hotend.
  • tiene dos entradas de alimentación, una de 5A y otra de 11A. Ya lo comenté hace poco pero bueno, es como la ramps, hay que conectar solo el de 5A si no usamos cama caliente y en nuestro caso, que si, hay que alimentar ambos.
  • en el github de staticboards hay un firmware subido ya preparado para la anet. Tiene configuración para ahorrar memoria en menús y tal, porque podía dar problemas de falta de memoria al poner autolevel. Habrá que editar cosas porque la nuestra es corexy. Ejes x e y llevan tmc2208, y es la versión 1.1.9 de Marlin
@JorFru

This comment has been minimized.

Copy link
Member

JorFru commented Oct 6, 2018

Tenemos un problema, se nos ha quemado un componente de la placa, parece que se trata de un regulador. Posiblemente sea el que da los 5V, pero no estoy seguro. Tenemos esta documentación, hay que pedirle el layout de componentes a Javier para averiguar de qué componente se trata.

Yo creo que esto se ha quemado porque los conectores de final de carrera no coinciden cable a cable. Por lo tanto se han conectado mal y han cortocircuitado los 5V. O bien han sido los sensores de temperatura mal conectados, aunque me parece muy raro.
imagen

En todo caso hay que pasar reporte a Javier y enterarnos de qué ese ese componente y con qué reemplazarlo. (lo haremos nosotros mismos).

@dmarcosm

This comment has been minimized.

Copy link
Contributor

dmarcosm commented Oct 6, 2018

Sigo sin entender por qué están conectados así. No habría sido mejor ponerle conectores?

@JorFru

This comment has been minimized.

Copy link
Member

JorFru commented Oct 6, 2018

Sigo sin entender por qué están conectados así. No habría sido mejor ponerle conectores?

Los conectores que venían eran de dos pines y no vi ninguno de tres en el armario.
Consulté el esquemático y ponerlo así me pareció la mejor manera. Parece que el pin de en medio no está conectado a nada, y el conector de dos sólo vale para pines correlativos.
imagen

@dmarcosm

This comment has been minimized.

Copy link
Contributor

dmarcosm commented Oct 6, 2018

Pues no sé. Ahora después digo a Javier que os meta a uno de los dos en el grupo de betatesters, que yo estoy hasta arriba ahora.

@JorFru

This comment has been minimized.

Copy link
Member

JorFru commented Oct 6, 2018

De cabeza entro en ese grupo.
No tengo tiempo
pero para hablar de electrónica estoy siempre disponible.

@Siotma

This comment has been minimized.

Copy link
Member

Siotma commented Oct 6, 2018

Puntualizar que no ha sido un regalo: #87

@JorFru JorFru self-assigned this Oct 16, 2018

@JorFru

This comment has been minimized.

Copy link
Member

JorFru commented Oct 16, 2018

Componentes pedidos. Estarán aquí a partir del 28 de octubre, creo.
Los pago de mi bolsillo, cuesta 0.12€.

@Siotma

This comment has been minimized.

Copy link
Member

Siotma commented Nov 3, 2018

@JorFru , algún dato interesante del último día para que conste?

@JorFru

This comment has been minimized.

Copy link
Member

JorFru commented Nov 3, 2018

El proveedor se equivocó y me mandó AMS1117-3.3 en vez de AMS1117-5.0
Conseguiré los reguladores correctos para instalarlos el lunes o martes después de la OSHWDem

@Siotma

This comment has been minimized.

Copy link
Member

Siotma commented Nov 20, 2018

Parece que la placa quedó reparada en la última sesión. @JorFru trató de flashear Marlin 1.1.9 sin éxito.

Hoy he estado investigando. He conseguido instalar la placa de la Anet en Arduino IDE siguiendo el tutorial: https://trello.com/c/QRIYELJA/311-configurar-arduino-ide-para-actualizar-el-firmware-a-partir-de-c%C3%B3digo-fuente

También he editado los archivos de configuración (adjuntos). Más info en la página oficial: https://www.staticboards.es/productos/ovm20anet/ y en github: https://gist.github.com/staticboards/441ee5d194fd3f69d54b6cffbad19161

Sin embargo, no he sido capaz de subir ningún firmware a la placa porque parece que no tiene bootloader. @dmarcosm dice que puede ocurrir que al programarla se borre, así que igual eso fue lo que le ocurrió a @JorFru . Habrá que usar un ISP, en ASROB tenemos este el USBTinyISP. En el siguiente enlace aparecen los esquemáticos de los conectores: https://cdn-learn.adafruit.com/downloads/pdf/usbtinyisp.pdf

Según @dmarcosm hay que conectarlo así.
ovm_isp

Configuration_Geonosis.zip

@GioSunrider

This comment has been minimized.

Copy link
Member

GioSunrider commented Dec 15, 2018

Me gustaría que actualizados el estado de la placa, si esta es funcional ya mismo, podéis proceder a cerrar la issue

@GioSunrider

This comment has been minimized.

Copy link
Member

GioSunrider commented Dec 20, 2018

Siguiendo el tutorial de staticsboards, que @Siotma proporciono, logre subir con exito el marlin 1.1.9, aunque los fichero que ha y en el repo de @dmarcosm estan mal configurados, ya que la pantalla ni la placa eran las correctas.
Cuando se fue a comprobar la placa ocurrio lo siguiente....

photo5825823451842195177

Se rompio el conector usb, por lo uqe planteo dos soluciones al problema.

  1. Si @JorFru puede repararlo, tiene via libre para hacerlo ya que la placa podemos actualizarla via programador, pero, no podemos conectarla a octoprint.
  2. Retornar a la paca original de TronXY

@GioSunrider GioSunrider moved this from Planned for next session to Important in Printer One: A Clone Wars Story Dec 20, 2018

@JorFru

This comment has been minimized.

Copy link
Member

JorFru commented Dec 28, 2018

Creo que puedo hacerlo.
Me propongo como plazo las dos primeras semanas de Enero.

Si necesitáis la máquina con el USB en funcionamiento antes de este periodo, podéis hacer lo que queráis, pero no me puedo comprometer a hacerlo en una fecha concreta.

@GioSunrider

This comment has been minimized.

Copy link
Member

GioSunrider commented Dec 28, 2018

No, no ha prisa, es más SAV, ya que todavía no hemos visto a geonosis quemando plástico. Pero no hay problema en tenerla parada, hay otras 4 Impresoras. Así que por mi parte tienes vía libre para ponerte con ella cuando puedas, te dejo encargado de esta issue para que hagas lo que creas mejor.

@Siotma

This comment has been minimized.

Copy link
Member

Siotma commented Jan 13, 2019

Siguiendo el tutorial de staticsboards, que @Siotma proporciono, logre subir con exito el marlin 1.1.9, aunque los fichero que ha y en el repo de @dmarcosm estan mal configurados, ya que la pantalla ni la placa eran las correctas.

Según dices, utilizaste las fuentes de @dmarcosm , sin embargo, yo te había dejado un zip con la configuración en mi post. Supongo que no lo viste. Estuve configurándolo un buen rato y busccando información para asegurarme de lo que hacía... debería funcionar bien.

@GioSunrider

This comment has been minimized.

Copy link
Member

GioSunrider commented Jan 13, 2019

Pues la verdad que no lo vi, seria subir ese a ver si funciona, pero antes hay que arreglar la placa.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment