Add 'coffee-script' to 'dependencies' at package.json #328

Closed
wants to merge 1 commit into
from

Projects

None yet

2 participants

@tricknotes

The npm module 'coffee-script' is requied
to compile client-side coffee-script.

@tricknotes tricknotes Add 'coffee-script' to 'dependencies' at package.json
The npm module 'coffee-script' is requied
to compile client-side coffee-script.
e22c395
@tricknotes

After 864d6c8, I can't require zombie installed via npm.

$ node -v
v0.6.16
$ npm install zombie
$ npm list 
/Users/tricknotes/mock
└─┬ zombie@0.13.7 
$ node
> require('zombie');
Error: Cannot find module 'coffee-script'
    at Function._resolveFilename (module.js:332:11)
    at Function._load (module.js:279:25)
    at Module.require (module.js:354:17)
    at require (module.js:370:17)
    at Object.<anonymous> (/Users/tricknotes/mock/node_modules/zombie/lib/zombie/scripts.js:4:16)
    at Module._compile (module.js:441:26)
    at Object..js (module.js:459:10)
    at Module.load (module.js:348:31)
    at Function._load (module.js:308:12)
    at Module.require (module.js:354:17)
@assaf
Owner

I actually don't want Coffee-Script to be a dependency, that caused a version conflict on one of our projects, so changing it to be an optional require.

cd0510d

@assaf assaf closed this May 4, 2012
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment