Permalink
Browse files

updating to use helper-lib from other repo and updating engine loader…

… to only call require and let the helper worry about registering the helpers
  • Loading branch information...
1 parent 37bb4d2 commit f3022059dfd12d7f481cd0d2e487fa9f16df4207 @doowb doowb committed Apr 6, 2013
Showing with 7 additions and 6 deletions.
  1. +5 −4 lib/utils/engineLoader.js
  2. +2 −2 package.json
@@ -1,6 +1,6 @@
/* ==========================================================
* lib/utils/engineLoader.js
- *
+ *
* Assemble
* http://assemble.io
*
@@ -25,7 +25,8 @@
var defaults = {
engine: 'handlebars',
- helpers: '../engines/handlebars/helpers/defaultHelpers.js',
+ //helpers: '../engines/handlebars/helpers/defaultHelpers.js',
+ helpers: ['helper-lib'],
preprocessors: false
};
this.options = _.extend(defaults, options);
@@ -81,7 +82,7 @@
}
for(var i=0; i < this.options.helpers.length; i++) {
- this.requireHelper(this.options.helpers[i]).register(engine);
+ this.requireHelper(this.options.helpers[i]); //.register(engine);
}
}
@@ -150,7 +151,7 @@
if(helper) { return helper; }
else { helper = false; fullPath = ''; }
- return null;
+ return helper;
};
View
@@ -40,7 +40,7 @@
"dependencies": {
"amdefine": "0.0.4",
"handlebars": "~1.0.10",
- "helper-lib": "~0.1.x",
+ "helper-lib": "git://github.com/assemble/helper-lib.git",
"highlight.js": "*",
"js-yaml": "~2.0.3",
"lodash": "~1.1.1",
@@ -115,4 +115,4 @@
"yaml data",
"web framework"
]
-}
+}

0 comments on commit f302205

Please sign in to comment.