Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Added necessary requires for the new virtualbox gem as suggested by @…

  • Loading branch information...
commit dc05a5218efa0b2fc6a0209cf0b79e6570473cbd 1 parent fd7b303
@jedi4ever jedi4ever authored
Showing with 17 additions and 16 deletions.
  1. +13 −15 Gemfile.lock
  2. +3 −0  lib/veewee/session.rb
  3. +1 −1  veewee.gemspec
View
28 Gemfile.lock
@@ -2,7 +2,7 @@ PATH
remote: .
specs:
veewee (0.2.0)
- cucumber (= 0.8.5)
+ cucumber (~> 1.0.2)
highline (~> 1.6.1)
net-ssh (~> 2.1.0)
popen4 (~> 0.1.2)
@@ -16,30 +16,29 @@ GEM
specs:
Platform (0.4.0)
archive-tar-minitar (0.5.2)
- builder (2.1.2)
- cucumber (0.8.5)
- builder (~> 2.1.2)
- diff-lcs (~> 1.1.2)
- gherkin (~> 2.1.4)
- json_pure (~> 1.4.3)
- term-ansicolor (~> 1.0.4)
+ builder (3.0.0)
+ cucumber (1.0.2)
+ builder (>= 2.1.2)
+ diff-lcs (>= 1.1.2)
+ gherkin (~> 2.4.5)
+ json (>= 1.4.6)
+ term-ansicolor (>= 1.0.5)
diff-lcs (1.1.2)
erubis (2.7.0)
ffi (1.0.9)
- gherkin (2.1.5)
- trollop (~> 1.16.2)
+ gherkin (2.4.5)
+ json (>= 1.4.6)
highline (1.6.2)
i18n (0.5.0)
json (1.5.3)
- json_pure (1.4.6)
net-scp (1.0.4)
net-ssh (>= 1.99.1)
net-ssh (2.1.4)
- open4 (1.0.1)
+ open4 (1.1.0)
popen4 (0.1.2)
Platform (>= 0.4.0)
open4 (>= 0.4.0)
- progressbar (0.9.0)
+ progressbar (0.9.1)
rspec (2.5.0)
rspec-core (~> 2.5.0)
rspec-expectations (~> 2.5.0)
@@ -48,9 +47,8 @@ GEM
rspec-expectations (2.5.0)
diff-lcs (~> 1.1.2)
rspec-mocks (2.5.0)
- term-ansicolor (1.0.5)
+ term-ansicolor (1.0.6)
thor (0.14.6)
- trollop (1.16.2)
vagrant (0.8.1)
archive-tar-minitar (= 0.5.2)
erubis (~> 2.7.0)
View
3  lib/veewee/session.rb
@@ -6,6 +6,9 @@
require 'progressbar'
require 'highline/import'
require 'tempfile'
+require 'virtualbox'
+require 'virtualbox/abstract_model'
+require 'virtualbox/ext/byte_normalizer'
module Veewee
View
2  veewee.gemspec
@@ -20,7 +20,7 @@ Gem::Specification.new do |s|
s.add_dependency "thor", "~> 0.14.6"
s.add_dependency "highline", "~> 1.6.1"
s.add_dependency "progressbar"
- s.add_dependency "cucumber", "0.8.5"
+ s.add_dependency "cucumber", "~> 1.0.2"
s.add_dependency "rspec", "~> 2.5.0"
#s.add_dependency "simon", "~> 0.1.1"
Please sign in to comment.
Something went wrong with that request. Please try again.