Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

npm install presents warning about puppeteer version #198

Closed
DuaneOBrien opened this issue Oct 6, 2019 · 2 comments

Comments

@DuaneOBrien
Copy link
Contributor

commented Oct 6, 2019

npm install or npm audit raises an alert about the required version of puppeteer.

Advisory is here.

Bumping puppeteer version to 1.13 in package.json should resolve.

@astefanutti

This comment has been minimized.

Copy link
Owner

commented Oct 7, 2019

I was holding the Puppeteer upgrade because of the following constraints:

  • The Chromium Alpine port should be available for the version used by Puppeteer, as Decktape Docker image uses Alpine base image,
  • There is a regression introduced in Chromium 75 (Puppeteer 1.15.0) that affects Mac OS PDF preview: https://crbug.com/995265.

That being said, upgrading to Puppeteer 1.13.0 satisfies these two constraints and should solve the security warning.

@astefanutti

This comment has been minimized.

Copy link
Owner

commented Oct 7, 2019

It should be fixed with d0fcbe5.

Thanks a lot for the report!

@astefanutti astefanutti closed this Oct 7, 2019
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
2 participants
You can’t perform that action at this time.