Skip to content
This repository
Fetching contributors…

Octocat-spinner-32-eaf2f5

Cannot retrieve contributors at this time

file 29 lines (22 sloc) 1.161 kb
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28
(See CHANGELOG.txt for lists of changes. This file provides
information for those upgrading from previous versions of stdeb.)

Release 0.4.2
=============

This is a bugfix release fixing a couple issues. The most significant
fix is that if a package specified "XS-Python-Version" in stdeb.cfg,
the binary package wouldn't install the Python packages.

No backwards incompatible changes were made with this release.

Release 0.4.1
=============

This release maintains backward compatibility with old versions of
stdeb and debhelper, but stdeb now allows packages that don't carry
the cruft of backward compatibility. To disable all backwards
compatibility, specify the --no-backwards-compatibility flag. This
will set --pycentral-backwards-compatibility=False and
--workaround-548392=False. You may set these flags individually if
desired.

By "maintains backward compatibility with stdeb", I mean that newer
packages made with newer stdeb (0.4.1 and up) will properly upgrade
from older package made with older versions of stdeb (less than
0.4.0). The problem, in particular, is the migration from
python-central. See Debian bug #479852 for more information.
Something went wrong with that request. Please try again.