Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

disable pycentral backwards compatibility by default

  • Loading branch information...
commit ae4a761e1c95c9a93c6379a752a8a63ce49b6bf0 1 parent 1ab3142
Andrew Straw authored
3  CHANGELOG.txt
View
@@ -1,5 +1,8 @@
2010-06-19 Do not workaround Debian Bug #548392 by default.
+2010-06-19 By default, do not attempt to migrate old stdeb based
+ packages that used pycentral.
+
= Release 0.6 (2010-06-18) =
2010-06-18 Do not die if sources.list does not contain deb-src
6 README.rst
View
@@ -441,9 +441,9 @@ To pass these commands to sdist_dsc when calling bdist_deb, do this::
--remove-expanded-source-dir (-r) remove the expanded source directory
--ignore-install-requires (-i) ignore the requirements from
requires.txt in the egg-info directory
- --pycentral-backwards-compatibility If True (currently the default), enable
- migration from old stdeb that used
- pycentral
+ --pycentral-backwards-compatibility If True, enable migration from old
+ stdeb that used pycentral.
+ (Default=False).
--workaround-548392 If True, limit binary package to single
Python version, working around Debian
bug 548392 of debhelper.
4 RELEASE_NOTES.txt
View
@@ -11,6 +11,10 @@ makes no effort to workaround this bug, and thus "XS-Python-Version:
all". If you are using stdeb on an older version of Debian/Ubuntu with
a buggy version of debhelper, use "--workaround-548392=True".
+Remove the default attempt to migrate old stdeb based packages that
+used pycentral. (If you still have old stdeb based packages, use
+"--pycentral-backwards-compatibility=True".
+
Release 0.6.0
=============
3  stdeb/command/common.py
View
@@ -74,8 +74,7 @@ def str_to_bool(mystr):
self.force_buildsystem = True
if self.pycentral_backwards_compatibility is None:
- self.pycentral_backwards_compatibility=True
- # emit future change warnging?
+ self.pycentral_backwards_compatibility=False
if self.guess_conflicts_provides_replaces is None:
# the default
3  stdeb/util.py
View
@@ -66,8 +66,7 @@ def check_call(*popenargs, **kwargs):
('ignore-install-requires', 'i',
'ignore the requirements from requires.txt in the egg-info directory'),
('pycentral-backwards-compatibility=',None,
- 'If True (currently the default), enable migration from old stdeb '
- 'that used pycentral'),
+ 'If True, enable migration from old stdeb that used pycentral. (Default=False).'),
('workaround-548392=',None,
'If True, limit binary package to single Python version, '
'working around Debian bug 548392 of debhelper. (Default=False).'),
Please sign in to comment.
Something went wrong with that request. Please try again.