Skip to content
This repository

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Web-based feed aggregator in Ruby

branch: em

This branch is 1 commit ahead and 1 commit behind master

Fetching latest commit…

Octocat-spinner-32-eaf2f5

Cannot retrieve the latest commit at this time

Octocat-spinner-32 html
Octocat-spinner-32 lib
Octocat-spinner-32 templates
Octocat-spinner-32 HTMLlat1.ent
Octocat-spinner-32 HTMLspecial.ent
Octocat-spinner-32 HTMLsymbol.ent
Octocat-spinner-32 README
Octocat-spinner-32 chart.rb
Octocat-spinner-32 config.yaml
Octocat-spinner-32 db.sql
Octocat-spinner-32 fetcher.rb
Octocat-spinner-32 generate.rb
Octocat-spinner-32 harvester-0.6-mysql.diff
Octocat-spinner-32 harvester-current-mysql.diff
Octocat-spinner-32 jabberbot.rb
Octocat-spinner-32 run.sh
README
Harvester 0.7
=============

Astro (2005-2008)
Neingeist
Tigion
Josef Spillner
Others (MySQL patch)


About
=====

The Harvester is a web-based RSS-Aggregator

A running instance can be seen at:
http://astroblog.spaceboyz.net/harvester/


Changes
=======
0.7:
 - XSLT templates
 - Reworked MRSS
 - HTML entity replacement
 - Transactional database handling
 - Favicon, style, photos
 - Microformats in HTML template
 - Chart timeline
 - Jabberbot fixes
 - HTTPS support optional
0.6:
 - Complete rewrite (excl. MRSS)
 - YAML configuration
 - Database backend (PostgreSQL)
 - Fetcher is not using wget anymore and supports SSL, HTTP authentication and If-Modified-Since
 - Fetcher operates threaded to request feeds parallelized
 - Minor template variables renaming
0.5:
 - Fixed a syntax error ;-)
 - Multiple further fixes
 - The Jabber-bot
 - ATOM support by Neingeist
0.4:
 - Blog variables available in <tmpl:iter-item/>
 - index.html Template readability improvements, CSS now in extra
   file
0.3.2:
 - All template elements are now escaped by default. Use
   escape="false" if you really don't want to escape HTML-Tags and
   such...
0.3.1:
 - Fixed bug where incorrect encoded feeds won't be displayed when
   parsed for the first time
0.3:
 - Major overhaul


Installation
============

- Prereq: Gentoo, Debian, FreeBSD
- DB
- config.yaml
- cronjob
- Templates
- Chart
- Jabberbot

Something went wrong with that request. Please try again.