Error installing node-expat on FreeBSD #37

Closed
dhruvbird opened this Issue Jun 17, 2012 · 4 comments

Projects

None yet

2 participants

@dhruvbird

Some sort of compilation error while compiling node-expat on FreeBSD - about the header expat.h not being found even though it exists.

I'll fill in more details when I know them.

@astro
Owner

I guess wscript needs to find -I and -L with /usr/local or /usr/pkg

@dhruvbird

Yes. I think the expat.h file is in /usr/local/include and node /usr/include like in linux. Is there any way waf can be made to check both places by default? Probably /usr/include before /usr/local/include. I am guessing passing it into the include directive should do the trick?

@astro astro added a commit that referenced this issue Jun 22, 2012
@astro Merge 'dhruvbird/master'
Fixes Github issue #37
3a6d5e8
@astro
Owner

Thanks, Dhruv!

@astro astro closed this Jun 22, 2012
@dhruvbird

Always welcome :)

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment