Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

UnsatisfiableError: with numpy=stable and astropy=stable #166

Closed
hamogu opened this issue Feb 15, 2017 · 7 comments
Closed

UnsatisfiableError: with numpy=stable and astropy=stable #166

hamogu opened this issue Feb 15, 2017 · 7 comments
Labels

Comments

@hamogu
Copy link
Member

@hamogu hamogu commented Feb 15, 2017

In a package build with the package template, I'm now (after numpy stable was bumped up to 1.12) seeing:

UnsatisfiableError: The following specifications were found to be in conflict:
  - astropy
  - numpy 1.12*
  - python 3.6*

That's true both with python 3.5 and 3.6:

Either I'm overlooking something obvious or the required conda packages don't yet exist. In that case I suggest to roll back numpy to 1.11 for the time being (I've noticed that other affiliated packages ,e.g. photutils https://travis-ci.org/astropy/photutils/builds/202005537 seem to either pin numpy or astropy to an a specific version).

cc: @bsipocz

@bsipocz

This comment has been minimized.

Copy link
Member

@bsipocz bsipocz commented Feb 15, 2017

Ouch, good point, I checked the default channel last week, but haven't done it before merging the update. Apparently conda was quite slow this time around, both the python3.6 and the numpy updates came out weeks later than the official releases.

However I would rather try to build the new version combination in one of our channels than revert this change, also it's quite possible that conda-forge will have the update merged today.

@wtbarnes

This comment has been minimized.

Copy link

@wtbarnes wtbarnes commented Feb 16, 2017

I'm also having this UnsatisfiableError issue, but with 2.7, 3.4, and 3.5. The problem manifests itself a bit differently in each version (i.e. conflicts with different packages), but involves NumPy v1.12 in each case.

Travis build logs for reference:

@bsipocz

This comment has been minimized.

Copy link
Member

@bsipocz bsipocz commented Feb 16, 2017

@hamogu - We will definitely have a solution for the double stable case.

@wtbarnes - I'm afraid we don't have a good solution for you. Since you've pinned the pyqt version, I would suggest to use a given, fixed numpy version for those builds as we have won't be able to provide pyqt versions for different numpy versions. Alternatively if you know that they are available on a given conda channel, add that channel to the CONDA_CHANNELS variable. Another alternative is to install pyqt via PIP_DEPENDENCIES (I'm not sure how feasible that is).

@wtbarnes

This comment has been minimized.

Copy link

@wtbarnes wtbarnes commented Feb 16, 2017

@bsipocz Thanks for the tips. We'll probably pin NumPy to v1.11 for now. The pyqt version was pinned because of a conflict between pyqt5 and matplotlib I think.

@bsipocz

This comment has been minimized.

Copy link
Member

@bsipocz bsipocz commented Feb 16, 2017

matplotlib also have a new 2.0 out, you may be able to revise those version limitations with it...

@bsipocz

This comment has been minimized.

Copy link
Member

@bsipocz bsipocz commented Feb 16, 2017

A possible fix have been merged, @hamogu could you please restart your build?

@hamogu

This comment has been minimized.

Copy link
Member Author

@hamogu hamogu commented Feb 17, 2017

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
3 participants
You can’t perform that action at this time.