ruby bindings to libfreenect
Pull request Compare This branch is 10 commits behind schacon:master.
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Failed to load latest commit information.
examples
ext/kinectaby
lib
test
.gitignore
LICENSE
README.md
Rakefile
TODO.txt
kinectaby.gemspec

README.md

Kinectaby - libfreenect Ruby bindings

Kinectaby is a first pass at Ruby bindings to the amazing Kinect libfreenect driver.

INSTALLING AND RUNNING

First you need a Kinect.

Then you need to install libfreenect.

Next, you need to install rake-compiler:

$ sudo gem install rake-compiler

Then you need to get and compile this.

$ git clone git://github.com/schacon/kinectaby.git
$ cd kinectaby
$ rake compile
$ rake test

API

require 'kinectaby'

context = Kinectaby::Context.new
context.num_devices
context.shutdown

device = context.open_device(0)
device.set_led(Kinectaby::LED_RED)
device.close

CONTRIBUTING

Fork schacon/kinectaby on GitHub, make it awesomer (preferably in a branch named for the topic), send me a pull request.

AUTHORS

LICENSE

MIT. See LICENSE file.