New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Crash on lion #16

Open
atg opened this Issue Apr 21, 2011 · 13 comments

Comments

Projects
None yet
7 participants
@atg
Owner

atg commented Apr 21, 2011

...

@ghost

This comment has been minimized.

Show comment
Hide comment
@ghost

ghost Apr 25, 2011

Where 1.0 did work for me on Lion (11A430e), 1.1b1 crashes hard.

ghost commented Apr 25, 2011

Where 1.0 did work for me on Lion (11A430e), 1.1b1 crashes hard.

@nkulikov

This comment has been minimized.

Show comment
Hide comment
@nkulikov

nkulikov Jul 6, 2011

The same issue. Is crash report valuable?

nkulikov commented Jul 6, 2011

The same issue. Is crash report valuable?

@atg

This comment has been minimized.

Show comment
Hide comment
@atg

atg Jul 7, 2011

Owner

Hmm, I'll give it another test tomorrow.

Owner

atg commented Jul 7, 2011

Hmm, I'll give it another test tomorrow.

@ghost

This comment has been minimized.

Show comment
Hide comment
@ghost

ghost Jul 7, 2011

Here's the crash report in case you didn't happen to find it. I ran this against Lion GM.

Mark Grimes
mark@stateful.net

On Jul 6, 2011, at 7:53 PM, fileability wrote:

Hmm, I'll give it another test tomorrow.

Reply to this email directly or view it on GitHub:
#16 (comment)

ghost commented Jul 7, 2011

Here's the crash report in case you didn't happen to find it. I ran this against Lion GM.

Mark Grimes
mark@stateful.net

On Jul 6, 2011, at 7:53 PM, fileability wrote:

Hmm, I'll give it another test tomorrow.

Reply to this email directly or view it on GitHub:
#16 (comment)

@atg

This comment has been minimized.

Show comment
Hide comment
@atg

atg Jul 7, 2011

Owner

Don't think github likes attachments! hah

gist it?

Owner

atg commented Jul 7, 2011

Don't think github likes attachments! hah

gist it?

@ghost

This comment has been minimized.

Show comment
Hide comment
@ghost

ghost Jul 7, 2011

Hah I didn't notice because I was using email to continue the thread. Here is the gist:
https://gist.github.com/1070763

ghost commented Jul 7, 2011

Hah I didn't notice because I was using email to continue the thread. Here is the gist:
https://gist.github.com/1070763

@atg

This comment has been minimized.

Show comment
Hide comment
@atg

atg Jul 8, 2011

Owner

Very strange, it crashed in columnMallocFailure() in sqlite.

Owner

atg commented Jul 8, 2011

Very strange, it crashed in columnMallocFailure() in sqlite.

@jessearmand

This comment has been minimized.

Show comment
Hide comment
@jessearmand

jessearmand Jul 25, 2011

Yes, I see the exact same crash report as @mgrimes.

jessearmand commented Jul 25, 2011

Yes, I see the exact same crash report as @mgrimes.

@jeffdc

This comment has been minimized.

Show comment
Hide comment
@jeffdc

jeffdc Jul 30, 2011

It crashed for me in a similar way 5 times, though I got 5 different crashes, 4 EXC_BAD_ACCESSes and 1 SIGABRT. The oddest part is that the 5th time I opened it it worked just peachy. So it crashed 4 times in a row. Then worked. Then crashed again. Here are the 5 crash logs: https://gist.github.com/1115656

jeffdc commented Jul 30, 2011

It crashed for me in a similar way 5 times, though I got 5 different crashes, 4 EXC_BAD_ACCESSes and 1 SIGABRT. The oddest part is that the 5th time I opened it it worked just peachy. So it crashed 4 times in a row. Then worked. Then crashed again. Here are the 5 crash logs: https://gist.github.com/1115656

@ekurutepe

This comment has been minimized.

Show comment
Hide comment
@ekurutepe

ekurutepe Jul 30, 2011

I have the same issue. Here is my gist: https://gist.github.com/1116107

hope this helps.

ekurutepe commented Jul 30, 2011

I have the same issue. Here is my gist: https://gist.github.com/1116107

hope this helps.

@jeffdc

This comment has been minimized.

Show comment
Hide comment
@jeffdc

jeffdc Aug 5, 2011

Looks like a garbage collection related error. Maybe diff behavior on Lion vs SL. Not sure. I ran the latest source in the debugger and after indexing (which crashed twice) I got it to a reproducible state: search on any value that will return results, crash when it tries to display the results. I got the following bit of fun in the output:

Ingredients(10681,0x1004e5000) malloc: resurrection error for object 0x40046f4c0 while assigning >__NSDictionaryObjectEnumerator._origObj128[16] = __NSCFDictionary64
garbage pointer stored into reachable memory, break on auto_zone_resurrection_error to debug

It dies on line 737 IGKScraper.m in the implementation of - (void)scrape, this line:

NSArray *deprecatedObjects = [persistmoc executeFetchRequest:deprecatedObjectsFetch error:&err];

It throws in the executeFetchRequest.

Hopefully this will help a bit.

jeffdc commented Aug 5, 2011

Looks like a garbage collection related error. Maybe diff behavior on Lion vs SL. Not sure. I ran the latest source in the debugger and after indexing (which crashed twice) I got it to a reproducible state: search on any value that will return results, crash when it tries to display the results. I got the following bit of fun in the output:

Ingredients(10681,0x1004e5000) malloc: resurrection error for object 0x40046f4c0 while assigning >__NSDictionaryObjectEnumerator._origObj128[16] = __NSCFDictionary64
garbage pointer stored into reachable memory, break on auto_zone_resurrection_error to debug

It dies on line 737 IGKScraper.m in the implementation of - (void)scrape, this line:

NSArray *deprecatedObjects = [persistmoc executeFetchRequest:deprecatedObjectsFetch error:&err];

It throws in the executeFetchRequest.

Hopefully this will help a bit.

@anddam

This comment has been minimized.

Show comment
Hide comment
@anddam

anddam Jan 19, 2012

I'm experiencing the same error using 1.1b1 and 10.7.2
Occasionally the app doesn't crash after starting, roughly once in six consecutive restarts.

The report shows the following backtrace for the crashed thread:

Thread 4 Crashed:
0   net.fileability.ingredients     0x0000000100007855 sqlite3ApiExit + 24
1   net.fileability.ingredients     0x0000000100009a6d columnMallocFailure + 31
2   net.fileability.ingredients     0x0000000100009baf sqlite3_column_text + 42
3   net.fileability.ingredients     0x000000010009f00d -[FMResultSet stringForColumnIndex:] + 91
4   net.fileability.ingredients     0x0000000100062cff __38-[IGKLaunchController finishedLoading]_block_invoke_0 + 467
5   libdispatch.dylib               0x00007fff974fa8ba _dispatch_call_block_and_release + 18
6   libdispatch.dylib               0x00007fff974fc10a _dispatch_queue_drain + 264
7   libdispatch.dylib               0x00007fff974fbf66 _dispatch_queue_invoke + 54
8   libdispatch.dylib               0x00007fff974fb760 _dispatch_worker_thread2 + 198
9   libsystem_c.dylib               0x00007fff921f93da _pthread_wqthread + 316
10  libsystem_c.dylib               0x00007fff921fab85 start_wqthread + 13

anddam commented Jan 19, 2012

I'm experiencing the same error using 1.1b1 and 10.7.2
Occasionally the app doesn't crash after starting, roughly once in six consecutive restarts.

The report shows the following backtrace for the crashed thread:

Thread 4 Crashed:
0   net.fileability.ingredients     0x0000000100007855 sqlite3ApiExit + 24
1   net.fileability.ingredients     0x0000000100009a6d columnMallocFailure + 31
2   net.fileability.ingredients     0x0000000100009baf sqlite3_column_text + 42
3   net.fileability.ingredients     0x000000010009f00d -[FMResultSet stringForColumnIndex:] + 91
4   net.fileability.ingredients     0x0000000100062cff __38-[IGKLaunchController finishedLoading]_block_invoke_0 + 467
5   libdispatch.dylib               0x00007fff974fa8ba _dispatch_call_block_and_release + 18
6   libdispatch.dylib               0x00007fff974fc10a _dispatch_queue_drain + 264
7   libdispatch.dylib               0x00007fff974fbf66 _dispatch_queue_invoke + 54
8   libdispatch.dylib               0x00007fff974fb760 _dispatch_worker_thread2 + 198
9   libsystem_c.dylib               0x00007fff921f93da _pthread_wqthread + 316
10  libsystem_c.dylib               0x00007fff921fab85 start_wqthread + 13
@cgrushko

This comment has been minimized.

Show comment
Hide comment
@cgrushko

cgrushko Aug 17, 2012

@jeffdc This problem seems to be fixed with this pull request

cgrushko commented Aug 17, 2012

@jeffdc This problem seems to be fixed with this pull request

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment