Skip to content

Development

Corey Donohoe edited this page Feb 14, 2011 · 1 revision
Clone this wiki locally

Setup

You need nodejs version 0.2.4 or greater along with a few libraries.

Give nvm a try and you should be able to replicate:

nvm install v0.2.6
nvm use v0.2.6

Install npm

curl http://npmjs.org/install.sh | sh

Install the required libraries

npm install express coffee-script vows optparse ansi-color

Hacking

Edit the .coffee files in src. You can compile them to the lib directory as you're updating them.:

$ JENKINS_SERVER=http://localhost:8080 \
  JENKINS_PROJECT=orgname-projectname  \
  make dev

This leaves a process running that constantly recompiles your coffescript into javascript.

Something went wrong with that request. Please try again.