Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

[FIX] Update HTTParty to new version

fix problem with ruby 1.9.3 to parse json
  • Loading branch information...
commit 1f720c456a2217e556a84d1a80054051e0412a24 1 parent c513189
@ondrejbartas ondrejbartas authored
Showing with 21 additions and 18 deletions.
  1. +1 −2  Gemfile
  2. +1 −2  Rakefile
  3. +19 −14 toggl.gemspec
View
3  Gemfile
@@ -2,5 +2,4 @@ source 'http://rubygems.org'
gem "hirb"
gem "httparty"
-gem "chronic_duration"
-gem "crack"
+gem "chronic_duration"
View
3  Rakefile
@@ -12,8 +12,7 @@ begin
gem.authors = ["Koen Van der Auwera"]
gem.files = FileList['lib/**/*.rb']
gem.test_files = []
- gem.add_dependency('crack', '= 0.1.8')
- gem.add_dependency('httparty', '= 0.6.1')
+ gem.add_dependency('httparty', '>= 0.8.1')
gem.add_dependency('chronic_duration', '>= 0.9.0')
gem.add_dependency('hirb', '>= 0.3.1')
# gem is a Gem::Specification... see http://www.rubygems.org/read/chapter/20 for additional settings
View
33 toggl.gemspec
@@ -4,15 +4,14 @@
# -*- encoding: utf-8 -*-
Gem::Specification.new do |s|
- s.name = %q{toggl}
+ s.name = "toggl"
s.version = "0.3.0"
s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
s.authors = ["Koen Van der Auwera"]
- s.date = %q{2012-03-27}
- s.default_executable = %q{toggl}
- s.description = %q{Toggl provides a simple REST-style JSON API over standard HTTP - http://www.toggl.com}
- s.email = %q{koen@atog.be}
+ s.date = "2012-04-04"
+ s.description = "Toggl provides a simple REST-style JSON API over standard HTTP - http://www.toggl.com"
+ s.email = "koen@atog.be"
s.executables = ["toggl"]
s.extra_rdoc_files = [
"LICENSE",
@@ -23,28 +22,34 @@ Gem::Specification.new do |s|
"lib/toggl_cmd/runner.rb",
"lib/toggl_cmd/runner_options.rb"
]
- s.homepage = %q{http://github.com/atog/toggl}
+ s.homepage = "http://github.com/atog/toggl"
s.require_paths = ["lib"]
- s.rubygems_version = %q{1.6.2}
- s.summary = %q{Toggl api ruby gem}
+ s.rubygems_version = "1.8.10"
+ s.summary = "Toggl api ruby gem"
if s.respond_to? :specification_version then
s.specification_version = 3
if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
- s.add_runtime_dependency(%q<crack>, ["= 0.1.8"])
- s.add_runtime_dependency(%q<httparty>, ["= 0.6.1"])
+ s.add_runtime_dependency(%q<hirb>, [">= 0"])
+ s.add_runtime_dependency(%q<httparty>, [">= 0"])
+ s.add_runtime_dependency(%q<chronic_duration>, [">= 0"])
+ s.add_runtime_dependency(%q<httparty>, [">= 0.8.1"])
s.add_runtime_dependency(%q<chronic_duration>, [">= 0.9.0"])
s.add_runtime_dependency(%q<hirb>, [">= 0.3.1"])
else
- s.add_dependency(%q<crack>, ["= 0.1.8"])
- s.add_dependency(%q<httparty>, ["= 0.6.1"])
+ s.add_dependency(%q<hirb>, [">= 0"])
+ s.add_dependency(%q<httparty>, [">= 0"])
+ s.add_dependency(%q<chronic_duration>, [">= 0"])
+ s.add_dependency(%q<httparty>, [">= 0.8.1"])
s.add_dependency(%q<chronic_duration>, [">= 0.9.0"])
s.add_dependency(%q<hirb>, [">= 0.3.1"])
end
else
- s.add_dependency(%q<crack>, ["= 0.1.8"])
- s.add_dependency(%q<httparty>, ["= 0.6.1"])
+ s.add_dependency(%q<hirb>, [">= 0"])
+ s.add_dependency(%q<httparty>, [">= 0"])
+ s.add_dependency(%q<chronic_duration>, [">= 0"])
+ s.add_dependency(%q<httparty>, [">= 0.8.1"])
s.add_dependency(%q<chronic_duration>, [">= 0.9.0"])
s.add_dependency(%q<hirb>, [">= 0.3.1"])
end
Please sign in to comment.
Something went wrong with that request. Please try again.