Running download-atom-shell task fails with system cannot find the path specified (Windows) #2027

Closed
TrevorS opened this Issue May 7, 2014 · 8 comments

Comments

Projects
None yet
7 participants
@TrevorS

TrevorS commented May 7, 2014

After taking a fresh clone of the repository, I no longer have issues building ctags (#1950).

Now I am able to build the modules and de-dupe them. Instead I'm getting this error:

Installing language-yaml@0.6.0 ✓
Deduping modules ✓
Running "download-atom-shell" task
>> The system cannot find the path specified.
Aborted due to warnings.
C:\atom [master]>

This is the contents of atom/atom-shell:

C:\atom [master]> ls atom-shell


    Directory: C:\atom\atom-shell


Mode                LastWriteTime     Length Name
----                -------------     ------ ----
d----          5/7/2014   8:55 AM            resources
-a---          5/7/2014   8:55 AM    6439936 atom.exe
-a---          5/7/2014   8:55 AM   44535296 chromiumcontent.dll
-a---          5/7/2014   8:55 AM    5689000 content_shell.pak
-a---          5/7/2014   8:55 AM     717824 ffmpegsumo.dll
-a---          5/7/2014   8:55 AM    9956864 icudt.dll
-a---          5/7/2014   8:55 AM     765952 libGLESv2.dll
-a---          5/7/2014   8:55 AM       1055 LICENSE
-a---          5/7/2014   8:55 AM          7 version


C:\atom [master]>

If I run atom/atom-shell/atom.exe I get this window:
image

I don't see a log or anything to upload, is there one I'm not seeing?

@TrevorS

This comment has been minimized.

Show comment
Hide comment
@TrevorS

TrevorS May 7, 2014

I was able to build and install a copy of Atom for Windows.

Once script/build finished with an error, I ran:

C:\atom [master]> .\script\grunt install
Running "install" task
Done, without errors.

And could now launch Atom:
image

TrevorS commented May 7, 2014

I was able to build and install a copy of Atom for Windows.

Once script/build finished with an error, I ran:

C:\atom [master]> .\script\grunt install
Running "install" task
Done, without errors.

And could now launch Atom:
image

@Arduinology

This comment has been minimized.

Show comment
Hide comment
@Arduinology

Arduinology May 7, 2014

Running script\build a second time worked for me.

Running script\build a second time worked for me.

@probablycorey

This comment has been minimized.

Show comment
Hide comment
@probablycorey

probablycorey May 9, 2014

Member

What was the error when you ran script\build the first time?

Member

probablycorey commented May 9, 2014

What was the error when you ran script\build the first time?

@dav-s

This comment has been minimized.

Show comment
Hide comment
@dav-s

dav-s May 10, 2014

My build fails on Running "Install" task. with only Aborted due to warnings. and no other information. When I do .\script\grunt install it gives me the same error. Any ideas of how to get a more useful warning or a solution?

dav-s commented May 10, 2014

My build fails on Running "Install" task. with only Aborted due to warnings. and no other information. When I do .\script\grunt install it gives me the same error. Any ideas of how to get a more useful warning or a solution?

@dav-s

This comment has been minimized.

Show comment
Hide comment
@dav-s

dav-s May 10, 2014

Just did a new clean pull of the repo and started over. Ran .\script\build and failed the first time but finally worked on the second time. :)

dav-s commented May 10, 2014

Just did a new clean pull of the repo and started over. Ran .\script\build and failed the first time but finally worked on the second time. :)

@Repulsor

This comment has been minimized.

Show comment
Hide comment
@Repulsor

Repulsor May 13, 2014

I got the following error:

C:\Users\xxx\Documents\GitHub\atom [master]> script/build
npm WARN package.json github-url-from-git@1.1.1 No repository field.
gypnpm ERR! git-utils@1.3.0 install: node-gyp rebuild
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the git-utils@1.3.0 install script.
npm ERR! This is most likely a problem with the git-utils package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR! node-gyp rebuild
npm ERR! You can get their info via:
npm ERR! npm owner ls git-utils
npm ERR! There is likely additional logging output above.

npm ERR! System Windows_NT 6.1.7601
npm ERR! command "node" "C:\Users\xxx\Documents\GitHub\atom\build\node_modules\npm\bin\n
pm-cli.js" "--userconfig=C:\Users\xxx\Documents\GitHub\atom.npmrc" "install" "--quiet"
npm ERR! cwd C:\Users\xxx\Documents\GitHub\atom\apm
npm ERR! node -v v0.10.28
npm ERR! npm -v 1.4.10
npm ERR! code ELIFECYCLE

Looks like it is a git error, anyone there who can help me out? thx.

I got the following error:

C:\Users\xxx\Documents\GitHub\atom [master]> script/build
npm WARN package.json github-url-from-git@1.1.1 No repository field.
gypnpm ERR! git-utils@1.3.0 install: node-gyp rebuild
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the git-utils@1.3.0 install script.
npm ERR! This is most likely a problem with the git-utils package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR! node-gyp rebuild
npm ERR! You can get their info via:
npm ERR! npm owner ls git-utils
npm ERR! There is likely additional logging output above.

npm ERR! System Windows_NT 6.1.7601
npm ERR! command "node" "C:\Users\xxx\Documents\GitHub\atom\build\node_modules\npm\bin\n
pm-cli.js" "--userconfig=C:\Users\xxx\Documents\GitHub\atom.npmrc" "install" "--quiet"
npm ERR! cwd C:\Users\xxx\Documents\GitHub\atom\apm
npm ERR! node -v v0.10.28
npm ERR! npm -v 1.4.10
npm ERR! code ELIFECYCLE

Looks like it is a git error, anyone there who can help me out? thx.

probablycorey pushed a commit to electron-archive/grunt-download-electron that referenced this issue May 14, 2014

probablycorey
Make sure the atom-shell output directory exists.
This was causing errors on windows. Specifically atom/atom#2126 and
atom/atom#2027
@kevinsawicki

This comment has been minimized.

Show comment
Hide comment
@liuxiong332

This comment has been minimized.

Show comment
Hide comment
@liuxiong332

liuxiong332 Jun 5, 2015

Contributor

@EpicDavi I also encounter this error aborted due to warnings when run install task.
When I run grunt install -v, the terminal tell me more information about this error.
In my situation, there are some modules can't be find and then I reinstall these modules and everything is OK.

So, you also can try it.

Contributor

liuxiong332 commented Jun 5, 2015

@EpicDavi I also encounter this error aborted due to warnings when run install task.
When I run grunt install -v, the terminal tell me more information about this error.
In my situation, there are some modules can't be find and then I reinstall these modules and everything is OK.

So, you also can try it.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment