New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Update to require libgtk-3-0 #17350

Merged
merged 1 commit into from May 17, 2018

Conversation

Projects
None yet
2 participants
@Arcanemagus
Contributor

Arcanemagus commented May 17, 2018

Requirements

  • Filling out the template is required. Any pull request that does not include enough information to be reviewed in a timely manner may be closed at the maintainers' discretion.
  • All new code requires tests to ensure against regressions

Description of the Change

The new version of Chromium included with Electron 2.0 requires a newer version of libgtk to be installed on the system to run. This updates the version to match the one pulled from Chrome 64.0.3282.167-1, listed here.

Alternate Designs

None.

Why Should This Be In Core?

It fixes an issue with the current list of dependencies.

Benefits

Minimal installations of Debian based Linux will have a better list of dependencies.

Possible Drawbacks

Verification Process

I verified that before installing libgtk-3-0 on a minimal installation running atom-beta --version exits with code 127. After removing libgtk2.0 with sudo apt remove libgtk2.0 --assume-yes and installing libgtk-3-0 with sudo apt install --assume-yes --quiet --no-install-suggests --no-install-recommends libgtk-3-0 the tar release of Atom v1.28.0-beta0 is able to run atom --version.

Applicable Issues

None.

Update to require libgtk-3-0
The new version of Chromium included with Electron 2.0 requires a newer
version of `libgtk` to be installed on the system to run.
@daviwil

Thanks @Arcanemagus!

@Arcanemagus

This comment has been minimized.

Contributor

Arcanemagus commented May 17, 2018

Man, Travis really doesn't like having a network connection on these .deb update PR's 😆.

@Arcanemagus Arcanemagus merged commit 3f07f7b into master May 17, 2018

3 checks passed

ci/circleci Your tests passed on CircleCI!
Details
continuous-integration/appveyor/pr AppVeyor build succeeded
Details
continuous-integration/travis-ci/pr The Travis CI build passed
Details

@Arcanemagus Arcanemagus deleted the la-update-libgtk branch May 17, 2018

@Arcanemagus Arcanemagus added the linux label May 17, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment