This repository has been archived by the owner. It is now read-only.

Remove obsolete conditional re: `atom.workspace.observeActiveTextEditor` #46

Merged
merged 1 commit into from Aug 10, 2017

Conversation

Projects
None yet
1 participant
@jasonrudolph
Member

jasonrudolph commented Aug 8, 2017

This PR removes the conditional logic (originally introduced in #45) that tested for the existence of atom.workspace.observeActiveTextEditor. Now that Atom 1.19 has been released, we can safely expect atom.workspace.observeActiveTextEditor to be available: https://github.com/atom/atom/blob/v1.19.0/src/workspace.js#L689-L702

Remove obsolete conditional re: observeActiveTextEditor()
Now that 1.19 has shipped, we can expect
atom.workspace.observeActiveTextEditor to be available.

@jasonrudolph jasonrudolph merged commit 1d25514 into master Aug 10, 2017

2 checks passed

continuous-integration/appveyor/pr AppVeyor build succeeded
Details
continuous-integration/travis-ci/pr The Travis CI build passed
Details

@jasonrudolph jasonrudolph deleted the jr-remove-obsolete-conditional branch Aug 10, 2017

Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.