New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Update dependencies #94

Merged
merged 4 commits into from Nov 2, 2017

Conversation

Projects
None yet
1 participant
@50Wliu
Member

50Wliu commented Nov 1, 2017

Requirements

  • Filling out the template is required. Any pull request that does not include enough information to be reviewed in a timely manner may be closed at the maintainers' discretion.
  • All new code requires tests to ensure against regressions

Description of the Change

  • Use a newer Standard version to get rid of the babel-eslint package, thus saving space.
    • Use environments instead of defining all the globals
  • Update fs-plus to ^3 so that it can be deduped, thus saving even more space.

Alternate Designs

N/A

Benefits

Staying up to date, potential space savings through npm deduping.

Possible Drawbacks

None.

Applicable Issues

None.

50Wliu added some commits Nov 1, 2017

@50Wliu

This comment has been minimized.

Show comment
Hide comment
@50Wliu

50Wliu Nov 2, 2017

Member

This also happens to fix specs on Windows on master.

Member

50Wliu commented Nov 2, 2017

This also happens to fix specs on Windows on master.

@50Wliu 50Wliu merged commit f8ac3fe into master Nov 2, 2017

1 of 2 checks passed

continuous-integration/travis-ci/pr The Travis CI build could not complete due to an error
Details
continuous-integration/appveyor/pr AppVeyor build succeeded
Details

@50Wliu 50Wliu deleted the wl-update-dependencies branch Nov 2, 2017

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment